diff mbox

[v9,05/10] perl: add GDBM_File

Message ID 1349531633-26717-5-git-send-email-francois.perrad@gadz.org
State Accepted
Commit 1ff20d33e3f213ea1efc2e6939516b1ea43393c4
Headers show

Commit Message

Francois Perrad Oct. 6, 2012, 1:53 p.m. UTC
Signed-off-by: Francois Perrad <francois.perrad@gadz.org>
---
 package/perl/Config.in |    6 ++++++
 package/perl/perl.mk   |    3 +++
 2 files changed, 9 insertions(+)
diff mbox

Patch

diff --git a/package/perl/Config.in b/package/perl/Config.in
index 9a13223..6369243 100644
--- a/package/perl/Config.in
+++ b/package/perl/Config.in
@@ -23,6 +23,12 @@  config BR2_PACKAGE_PERL_DB_FILE
 	help
 	  Build the DB_File module.
 
+config BR2_PACKAGE_PERL_GDBM_FILE
+	bool "GDBM_File"
+	select BR2_PACKAGE_GDBM
+	help
+	  Build the GDBM_File module.
+
 endif
 
 comment "perl requires an architecture supported by qemu"
diff --git a/package/perl/perl.mk b/package/perl/perl.mk
index fbaba54..0f12044 100644
--- a/package/perl/perl.mk
+++ b/package/perl/perl.mk
@@ -16,6 +16,9 @@  PERL_DEPENDENCIES = host-qemu
 ifeq ($(BR2_PACKAGE_BERKELEYDB),y)
     PERL_DEPENDENCIES += berkeleydb
 endif
+ifeq ($(BR2_PACKAGE_GDBM),y)
+    PERL_DEPENDENCIES += gdbm
+endif
 
 PERL_CONF_OPT = -des \
 		-Dusecrosscompile \