diff mbox

Makefile: Remove more pkgconfig files

Message ID 1349203935-20225-1-git-send-email-gvaxon@gmail.com
State Accepted
Commit 94d3aa171cfa72405c51686c82164d5af246f7bd
Headers show

Commit Message

Valentine Barshak Oct. 2, 2012, 6:52 p.m. UTC
The pkgconfig files are located in  /usr/lib/pkgconfig
and /usr/share/pkgconfig directories.
However, only /usr/lib/pkgconfig is removed when no
development files are needed in the target filesystem.

Remove pkgconfig directory from $(TARGET_DIR)/usr/share
as well if BR2_HAVE_DEVFILES is not set.

Signed-off-by: Valentine Barshak <gvaxon@gmail.com>
---
 Makefile | 3 ++-
 1 file changed, 2 insertions(+), 1 deletion(-)

Comments

Peter Korsgaard Oct. 4, 2012, 9:04 p.m. UTC | #1
>>>>> "Valentine" == Valentine Barshak <gvaxon@gmail.com> writes:

 Valentine> The pkgconfig files are located in  /usr/lib/pkgconfig
 Valentine> and /usr/share/pkgconfig directories.
 Valentine> However, only /usr/lib/pkgconfig is removed when no
 Valentine> development files are needed in the target filesystem.

 Valentine> Remove pkgconfig directory from $(TARGET_DIR)/usr/share
 Valentine> as well if BR2_HAVE_DEVFILES is not set.

Committed, thanks.
diff mbox

Patch

diff --git a/Makefile b/Makefile
index 6536bca..0128839 100644
--- a/Makefile
+++ b/Makefile
@@ -419,7 +419,8 @@  target-finalize:
 ifeq ($(BR2_HAVE_DEVFILES),y)
 	( support/scripts/copy.sh $(STAGING_DIR) $(TARGET_DIR) )
 else
-	rm -rf $(TARGET_DIR)/usr/include $(TARGET_DIR)/usr/lib/pkgconfig $(TARGET_DIR)/usr/share/aclocal
+	rm -rf $(TARGET_DIR)/usr/include $(TARGET_DIR)/usr/share/aclocal \
+		$(TARGET_DIR)/usr/lib/pkgconfig $(TARGET_DIR)/usr/share/pkgconfig
 	find $(TARGET_DIR)/lib \( -name '*.a' -o -name '*.la' \) -print0 | xargs -0 rm -f
 	find $(TARGET_DIR)/usr/lib \( -name '*.a' -o -name '*.la' \) -print0 | xargs -0 rm -f
 endif