diff mbox

[PATCHv2,4/4] iw: pkg-config nitpicking

Message ID 1348656522-13698-4-git-send-email-gustavo@zacarias.com.ar
State Superseded
Headers show

Commit Message

Gustavo Zacarias Sept. 26, 2012, 10:48 a.m. UTC
Since we're now using pkgconf with a wrapper script we no longer need to
pass PKG_CONFIG_PATH to pkg-config to do the right thing.
Also point PKG_CONFIG to PKG_CONFIG_HOST_BINARY rather than the
hardcoded option.

Signed-off-by: Gustavo Zacarias <gustavo@zacarias.com.ar>
---
 package/iw/iw.mk |    4 +---
 1 files changed, 1 insertions(+), 3 deletions(-)

Comments

Arnout Vandecappelle Sept. 27, 2012, 9:40 p.m. UTC | #1
On 26/09/12 12:48, Gustavo Zacarias wrote:
> Since we're now using pkgconf with a wrapper script we no longer need to
> pass PKG_CONFIG_PATH to pkg-config to do the right thing.
> Also point PKG_CONFIG to PKG_CONFIG_HOST_BINARY rather than the
> hardcoded option.
>
> Signed-off-by: Gustavo Zacarias<gustavo@zacarias.com.ar>
> ---
>   package/iw/iw.mk |    4 +---
>   1 files changed, 1 insertions(+), 3 deletions(-)
>
> diff --git a/package/iw/iw.mk b/package/iw/iw.mk
> index b1a86b3..af11140 100644
> --- a/package/iw/iw.mk
> +++ b/package/iw/iw.mk
> @@ -9,9 +9,7 @@ IW_SOURCE = iw-$(IW_VERSION).tar.bz2
>   IW_SITE = http://wireless.kernel.org/download/iw
>   IW_DEPENDENCIES = host-pkgconf libnl
>   IW_CONFIG = $(IW_DIR)/.config
> -IW_MAKE_ENV = PKG_CONFIG_PATH="$(STAGING_DIR)/usr/lib/pkgconfig" \
> -	PKG_CONFIG="$(HOST_DIR)/usr/bin/pkg-config" \
> -	GIT_DIR=$(IW_DIR)
> +IW_MAKE_ENV = PKG_CONFIG="$(PKG_CONFIG_HOST_BINARY)"
>
>   ifeq ($(BR2_PREFER_STATIC_LIB),y)
>   # libnl needs pthread/m, so we need to explicitly with them when static

Doesn't removing GIT_DIR break version.sh?

Regards,
Arnout
Gustavo Zacarias Sept. 27, 2012, 10:27 p.m. UTC | #2
On 09/27/12 18:40, Arnout Vandecappelle wrote:
> Doesn't removing GIT_DIR break version.sh?

Oh yes it does on dirty, my bad for being to 'dd' happy.
I'll resend the whole set once it's decided what to do about pkg-config.
IMHO host-pkg-config can be killed with fire, no need to duplicate it.
pkg-config might be deprecated as per the usual rite, though it's
duplicate functionality and could be just killed being a piggy with glib
deps :)
Regards.
Thomas Petazzoni Sept. 28, 2012, 2:12 p.m. UTC | #3
On Thu, 27 Sep 2012 19:27:06 -0300, Gustavo Zacarias wrote:
> On 09/27/12 18:40, Arnout Vandecappelle wrote:
> > Doesn't removing GIT_DIR break version.sh?
> 
> Oh yes it does on dirty, my bad for being to 'dd' happy.
> I'll resend the whole set once it's decided what to do about pkg-config.
> IMHO host-pkg-config can be killed with fire, no need to duplicate it.
> pkg-config might be deprecated as per the usual rite, though it's
> duplicate functionality and could be just killed being a piggy with glib
> deps :)

I agree that we don't need a deprecation period for pkg-config. It is
just an internal build dependency, nobody cares about it, especially if
there is a drop-in replacement for it.

Best regards,

Thomas
diff mbox

Patch

diff --git a/package/iw/iw.mk b/package/iw/iw.mk
index b1a86b3..af11140 100644
--- a/package/iw/iw.mk
+++ b/package/iw/iw.mk
@@ -9,9 +9,7 @@  IW_SOURCE = iw-$(IW_VERSION).tar.bz2
 IW_SITE = http://wireless.kernel.org/download/iw
 IW_DEPENDENCIES = host-pkgconf libnl
 IW_CONFIG = $(IW_DIR)/.config
-IW_MAKE_ENV = PKG_CONFIG_PATH="$(STAGING_DIR)/usr/lib/pkgconfig" \
-	PKG_CONFIG="$(HOST_DIR)/usr/bin/pkg-config" \
-	GIT_DIR=$(IW_DIR)
+IW_MAKE_ENV = PKG_CONFIG="$(PKG_CONFIG_HOST_BINARY)"
 
 ifeq ($(BR2_PREFER_STATIC_LIB),y)
 # libnl needs pthread/m, so we need to explicitly with them when static