diff mbox

[08/11] package/pulseaudio: fix build-dependency on gettext

Message ID 1347836276-24262-9-git-send-email-yann.morin.1998@free.fr
State Superseded
Headers show

Commit Message

Yann E. MORIN Sept. 16, 2012, 10:57 p.m. UTC
In its Config.in, pulseaudio declares a dependency on gettext
using the documented construct:
    select BR2_PACKAGE_GETTEXT if BR2_NEEDS_GETTEXT

but in its .mk file, declares a dependency on the package:
    PULSEAUDIO_DEPENDENCIES = [...] $(if $(BR2_PACKAGE_GETTEXT),gettext) [...]

instead of the documented:
    $(if $(BR2_NEEDS_GETTEXT),gettext)

Fix that.

Signed-off-by: "Yann E. MORIN" <yann.morin.1998@free.fr>
Tested-by: Arnout Vandecappelle (Essensium/Mind) <arnout@mind.be>
Acked-by: Arnout Vandecappelle (Essensium/Mind) <arnout@mind.be>
CC: Samuel Martin <s.martin49@gmail.com>
---
 package/multimedia/pulseaudio/pulseaudio.mk |    2 +-
 1 files changed, 1 insertions(+), 1 deletions(-)

Comments

Thomas Petazzoni Sept. 18, 2012, 5:58 p.m. UTC | #1
Dear Yann E. MORIN,

On Mon, 17 Sep 2012 00:57:53 +0200, Yann E. MORIN wrote:
> In its Config.in, pulseaudio declares a dependency on gettext
> using the documented construct:
>     select BR2_PACKAGE_GETTEXT if BR2_NEEDS_GETTEXT
> 
> but in its .mk file, declares a dependency on the package:
>     PULSEAUDIO_DEPENDENCIES = [...] $(if $(BR2_PACKAGE_GETTEXT),gettext) [...]
> 
> instead of the documented:
>     $(if $(BR2_NEEDS_GETTEXT),gettext)
> 
> Fix that.

Some other packages seem to suffer from the same problem, for example
diffutils. Why are you fixing pulseaudio separately, and not diffutils,
which gets fixed in your 11/11 patch:

-DIFFUTILS_DEPENDENCIES = \
-       $(if $(BR2_PACKAGE_GETTEXT),gettext)
+DIFFUTILS_DEPENDENCIES = $(gettext)

Thomas
Yann E. MORIN Sept. 18, 2012, 8:45 p.m. UTC | #2
Thomas, All,

On Tuesday 18 September 2012 19:58:40 Thomas Petazzoni wrote:
> On Mon, 17 Sep 2012 00:57:53 +0200, Yann E. MORIN wrote:
> > In its Config.in, pulseaudio declares a dependency on gettext
> > using the documented construct:
> >     select BR2_PACKAGE_GETTEXT if BR2_NEEDS_GETTEXT
> > 
> > but in its .mk file, declares a dependency on the package:
> >     PULSEAUDIO_DEPENDENCIES = [...] $(if $(BR2_PACKAGE_GETTEXT),gettext) [...]
> > 
> > instead of the documented:
> >     $(if $(BR2_NEEDS_GETTEXT),gettext)
> > 
> > Fix that.
> 
> Some other packages seem to suffer from the same problem, for example
> diffutils. Why are you fixing pulseaudio separately, and not diffutils,
> which gets fixed in your 11/11 patch:
> 
> -DIFFUTILS_DEPENDENCIES = \
> -       $(if $(BR2_PACKAGE_GETTEXT),gettext)
> +DIFFUTILS_DEPENDENCIES = $(gettext)

Yes, that's an oversight on my part. I quickly fixed it when I encountered
the issue, and forgot to extract it into their own cset.

I'll separate that, wait for some more review a litle longer, and repost
the series later.

Regards,
Yann E. MORIN.
diff mbox

Patch

diff --git a/package/multimedia/pulseaudio/pulseaudio.mk b/package/multimedia/pulseaudio/pulseaudio.mk
index 6f7d7d2..406dd8f 100644
--- a/package/multimedia/pulseaudio/pulseaudio.mk
+++ b/package/multimedia/pulseaudio/pulseaudio.mk
@@ -16,7 +16,7 @@  PULSEAUDIO_CONF_OPT = \
 
 PULSEAUDIO_DEPENDENCIES = \
 	host-pkg-config libtool json-c libsndfile speex host-intltool \
-	$(if $(BR2_PACKAGE_GETTEXT),gettext) \
+	$(if $(BR2_NEEDS_GETTEXT),gettext) \
 	$(if $(BR2_PACKAGE_LIBATOMIC_OPS),libatomic_ops) \
 	$(if $(BR2_PACKAGE_LIBSAMPLERATE),libsamplerate) \
 	$(if $(BR2_PACKAGE_ALSA_LIB),alsa-lib) \