diff mbox

qtuio: new package

Message ID 1346328506-27403-1-git-send-email-sho@relinux.de
State Superseded
Headers show

Commit Message

Stephan Hoffmann Aug. 30, 2012, 12:08 p.m. UTC
Implementation of an interface connecting TUIO messages and QT events

https://github.com/x29a/qTUIO

Signed-off-by: Stephan Hoffmann <sho@relinux.de>
---
Included fixes suggested by Thomas Petazzoni
Removed dependency from mtdev2tuio
Install library to staging

 package/Config.in       |    3 ++
 package/qtuio/Config.in |   18 ++++++++++++
 package/qtuio/qtuio.mk  |   70 +++++++++++++++++++++++++++++++++++++++++++++++
 3 files changed, 91 insertions(+), 0 deletions(-)
 create mode 100644 package/qtuio/Config.in
 create mode 100644 package/qtuio/qtuio.mk

Comments

Arnout Vandecappelle Sept. 11, 2012, 9:38 p.m. UTC | #1
On 08/30/12 14:08, Stephan Hoffmann wrote:
> Implementation of an interface connecting TUIO messages and QT events
>
> https://github.com/x29a/qTUIO
>
> Signed-off-by: Stephan Hoffmann<sho@relinux.de>

  Minor comments below, but regardless:

Acked-by: Arnout Vandecappelle (Essensium/Mind) <arnout@mind.be>
Tested-by: Arnout Vandecappelle (Essensium/Mind) <arnout@mind.be>
  build-tested with a minimal internal toolchain for ARM.

> ---
> Included fixes suggested by Thomas Petazzoni
> Removed dependency from mtdev2tuio
> Install library to staging
>
>   package/Config.in       |    3 ++
>   package/qtuio/Config.in |   18 ++++++++++++
>   package/qtuio/qtuio.mk  |   70 +++++++++++++++++++++++++++++++++++++++++++++++
>   3 files changed, 91 insertions(+), 0 deletions(-)
>   create mode 100644 package/qtuio/Config.in
>   create mode 100644 package/qtuio/qtuio.mk
>
> diff --git a/package/Config.in b/package/Config.in
> index e129522..94430b0 100644
> --- a/package/Config.in
> +++ b/package/Config.in
> @@ -134,6 +134,9 @@ source "package/efl/Config.in"
>   source "package/qt/Config.in"
>   source "package/x11r7/Config.in"
>
> +comment "QT libraries and helper libraries"
> +source "package/qtuio/Config.in"
> +

  Put this before x11r7.

>   comment "X libraries and helper libraries"
>   source "package/liberation/Config.in"
>   source "package/libsexy/Config.in"
[snip]
> +# Unfortunatelly, there is no working "install" target available
                 ^ one l: Unfortunately


[snip]

  Regards,
  Arnout
Arnout Vandecappelle Sept. 12, 2012, 7:13 a.m. UTC | #2
On 09/11/12 23:38, Arnout Vandecappelle wrote:
>> +comment "QT libraries and helper libraries"
>> +source "package/qtuio/Config.in"
>> +
>
>   Put this before x11r7.

  Actually, I'd also prefer this (both comment and source lines) to
be wrapped in a "if BR2_PACKAGE_QT".

  Regards,
  Arnout
diff mbox

Patch

diff --git a/package/Config.in b/package/Config.in
index e129522..94430b0 100644
--- a/package/Config.in
+++ b/package/Config.in
@@ -134,6 +134,9 @@  source "package/efl/Config.in"
 source "package/qt/Config.in"
 source "package/x11r7/Config.in"
 
+comment "QT libraries and helper libraries"
+source "package/qtuio/Config.in"
+
 comment "X libraries and helper libraries"
 source "package/liberation/Config.in"
 source "package/libsexy/Config.in"
diff --git a/package/qtuio/Config.in b/package/qtuio/Config.in
new file mode 100644
index 0000000..19499fd
--- /dev/null
+++ b/package/qtuio/Config.in
@@ -0,0 +1,18 @@ 
+config BR2_PACKAGE_QTUIO
+	bool "qtuio"
+	depends on BR2_PACKAGE_QT_GUI_MODULE
+	help
+	  Implementation of an interface connecting TUIO messages
+	  and QT events
+
+	  https://github.com/x29a/qTUIO
+
+config BR2_QTUIO_EXAMPLES
+	bool "qtuio examples"
+	depends on BR2_PACKAGE_QTUIO
+	help
+	  Build and install qtuio examples
+
+comment "qtuio depends on QT gui module"
+	depends on !BR2_PACKAGE_QT_GUI_MODULE
+
diff --git a/package/qtuio/qtuio.mk b/package/qtuio/qtuio.mk
new file mode 100644
index 0000000..5451052
--- /dev/null
+++ b/package/qtuio/qtuio.mk
@@ -0,0 +1,70 @@ 
+#############################################################
+#
+# qTUIO
+#
+#############################################################
+QTUIO_VERSION = abe4973ff6
+QTUIO_SITE = git://github.com/x29a/qTUIO.git
+QTUIO_INSTALL_STAGING = YES
+QTUIO_DEPENDENCIES = qt
+
+QTUIO_LICENSE = GPLv3+
+QTUIO_LICENSE_FILES = COPYING
+
+# The pong example needs QtOpenGL support, which might become available
+# some time in the future. Then add pong to the list of examples.
+QTUIO_EXAMPLES = dials fingerpaint knobs pinchzoom
+
+ifeq ($(BR2_QTUIO_EXAMPLES),y)
+define QTUIO_CONFIGURE_EXAMPLES
+	for example in $(QTUIO_EXAMPLES) ; do \
+		(cd $(@D)/examples/$${example} && $(QT_QMAKE)) ; \
+	done
+endef
+endif
+
+define QTUIO_CONFIGURE_CMDS
+	cd $(@D)/src && $(QT_QMAKE)
+	$(QTUIO_CONFIGURE_EXAMPLES)
+endef
+
+ifeq ($(BR2_QTUIO_EXAMPLES),y)
+define QTUIO_BUILD_EXAMPLES
+	for example in $(QTUIO_EXAMPLES) ; do \
+		($(MAKE) -C $(@D)/examples/$${example}) ; \
+	done
+endef
+endif
+
+define QTUIO_BUILD_CMDS
+	$(MAKE) -C $(@D)/src
+	$(QTUIO_BUILD_EXAMPLES)
+endef
+
+# Unfortunatelly, there is no working "install" target available
+ifeq ($(BR2_QTUIO_EXAMPLES),y)
+define QTUIO_INSTALL_EXAMPLES
+	for example in $(QTUIO_EXAMPLES) ; do \
+		($(INSTALL) -D -m 0755 $(@D)/examples/$${example}/$${example} $(TARGET_DIR)/usr/share/qtuio/$${example}) ; \
+	done
+endef
+endif
+
+define QTUIO_INSTALL_TARGET_CMDS
+	cp -dpf $(@D)/lib/libqTUIO.so* $(TARGET_DIR)/usr/lib
+	$(QTUIO_INSTALL_EXAMPLES)
+endef
+
+define QTUIO_INSTALL_STAGING_CMDS
+	cp -dpf $(@D)/lib/libqTUIO.so* $(STAGING_DIR)/usr/lib
+endef
+
+define QTUIO_CLEAN_CMDS
+	$(MAKE) -C $(@D)/src clean
+	for example in $(QTUIO_EXAMPLES) ; do \
+		($(MAKE) -C $(@D)/examples/$${example} clean) ; \
+	done
+endef
+
+
+$(eval $(generic-package))