diff mbox

pkg-infra: warn about use of deprecated GENTARGETS

Message ID 1346200620-11644-1-git-send-email-arnout@mind.be
State Accepted
Commit 5e0d702b7cfa09c9b4b4b0047b10be9f8bbf95a9
Headers show

Commit Message

Arnout Vandecappelle Aug. 29, 2012, 12:37 a.m. UTC
With the replacement of GENTARGETS by package-generic, there is a risk
that local packages don't work anymore without any indication of what
is wrong.  Therefore, generate an error message if the GENTARGETS,
AUTOTARGETS or CMAKETARGETS macro is still used.

Signed-off-by: Arnout Vandecappelle (Essensium/Mind) <arnout@mind.be>

---
 package/Makefile.in |    6 ++++++
 1 file changed, 6 insertions(+)

Comments

Arnout Vandecappelle Aug. 29, 2012, 12:39 a.m. UTC | #1
On 08/29/12 02:37, Arnout Vandecappelle (Essensium/Mind) wrote:
> With the replacement of GENTARGETS by package-generic, there is a risk
> that local packages don't work anymore without any indication of what
> is wrong.  Therefore, generate an error message if the GENTARGETS,
> AUTOTARGETS or CMAKETARGETS macro is still used.
>
> Signed-off-by: Arnout Vandecappelle (Essensium/Mind)<arnout@mind.be>

  Note: this is for master, perhaps it can be left out of next.

  Note2: I only tested it with AUTOTARGETS.

  Regards,
  Arnout
Peter Korsgaard Sept. 5, 2012, 8:56 p.m. UTC | #2
>>>>> "Arnout" == Arnout Vandecappelle (Essensium/Mind) <arnout@mind.be> writes:

 Arnout> With the replacement of GENTARGETS by package-generic, there is a risk
 Arnout> that local packages don't work anymore without any indication of what
 Arnout> is wrong.  Therefore, generate an error message if the GENTARGETS,
 Arnout> AUTOTARGETS or CMAKETARGETS macro is still used.

 Arnout> Signed-off-by: Arnout Vandecappelle (Essensium/Mind) <arnout@mind.be>

Commmitted, thanks.
diff mbox

Patch

diff --git a/package/Makefile.in b/package/Makefile.in
index 6fad224..2502602 100644
--- a/package/Makefile.in
+++ b/package/Makefile.in
@@ -304,6 +304,12 @@  else
 SHARED_STATIC_LIBS_OPTS=--enable-static --enable-shared
 endif
 
+# Warn if a package uses the deprecated GENTARGETS macros.  This can be
+# removed again for BR-2012.11.
+GENTARGETS = $$(error The GENTARGETS macro no longer exists; use $$$$(eval $$$$(generic-package)) or $$$$(eval $$$$(host-generic-package)))
+AUTOTARGETS = $$(error The AUTOTARGETS macro no longer exists; use $$$$(eval $$$$(autotools-package)) or $$$$(eval $$$$(host-autotools-package)))
+CMAKETARGETS = $$(error The CMAKETARGETS macro no longer exists; use $$$$(eval $$$$(cmake-package)) or $$$$(eval $$$$(host-cmake-package)))
+
 include package/pkg-utils.mk
 include package/pkg-download.mk
 include package/pkg-autotools.mk