diff mbox

uboot: add AIS binary target format

Message ID 1344474253-19265-1-git-send-email-vivien.didelot@savoirfairelinux.com
State Superseded
Headers show

Commit Message

Vivien Didelot Aug. 9, 2012, 1:04 a.m. UTC
This format embeds the SPL boot code with U-Boot, which is necessary on
TI platforms such as the DA850.

Signed-off-by: Vivien Didelot <vivien.didelot@savoirfairelinux.com>
---
 boot/uboot/Config.in | 3 +++
 boot/uboot/uboot.mk  | 3 +++
 2 files changed, 6 insertions(+)

Comments

Thomas Petazzoni Aug. 9, 2012, 8:23 a.m. UTC | #1
Hello,

Le Wed,  8 Aug 2012 21:04:13 -0400,
Vivien Didelot <vivien.didelot@savoirfairelinux.com> a écrit :

> This format embeds the SPL boot code with U-Boot, which is necessary
> on TI platforms such as the DA850.
> 
> Signed-off-by: Vivien Didelot <vivien.didelot@savoirfairelinux.com>
> ---
>  boot/uboot/Config.in | 3 +++
>  boot/uboot/uboot.mk  | 3 +++
>  2 files changed, 6 insertions(+)
> 
> diff --git a/boot/uboot/Config.in b/boot/uboot/Config.in
> index afc2f91..7f4b076 100644
> --- a/boot/uboot/Config.in
> +++ b/boot/uboot/Config.in
> @@ -80,6 +80,9 @@ endif
>  choice
>  	prompt "U-Boot binary format"
>  

Could you add a 'default BR2_TARGET_UBOOT_FORM_BIN' here, so that even
though u-boot.bin is no longer the first choice (and therefore the
default one), it remains the one selected by default?

> +config BR2_TARGET_UBOOT_FORMAT_AIS
> +	bool "u-boot.ais"
> +

Could you add a help text that mentions which platforms use this
format? For newcomers, it's not necessarily easy to find which image
format they should use, especially amongst the numerous SoC-specific
formats.

Otherwise, looks good, thanks!

Thomas
diff mbox

Patch

diff --git a/boot/uboot/Config.in b/boot/uboot/Config.in
index afc2f91..7f4b076 100644
--- a/boot/uboot/Config.in
+++ b/boot/uboot/Config.in
@@ -80,6 +80,9 @@  endif
 choice
 	prompt "U-Boot binary format"
 
+config BR2_TARGET_UBOOT_FORMAT_AIS
+	bool "u-boot.ais"
+
 config BR2_TARGET_UBOOT_FORMAT_BIN
 	bool "u-boot.bin"
 
diff --git a/boot/uboot/uboot.mk b/boot/uboot/uboot.mk
index 9e03d6a..b61400e 100644
--- a/boot/uboot/uboot.mk
+++ b/boot/uboot/uboot.mk
@@ -25,6 +25,9 @@  endif
 ifeq ($(BR2_TARGET_UBOOT_FORMAT_KWB),y)
 UBOOT_BIN          = u-boot.kwb
 UBOOT_MAKE_TARGET  = $(UBOOT_BIN)
+else ifeq ($(BR2_TARGET_UBOOT_FORMAT_AIS),y)
+UBOOT_BIN          = u-boot.ais
+UBOOT_MAKE_TARGET  = $(UBOOT_BIN)
 else ifeq ($(BR2_TARGET_UBOOT_FORMAT_LDR),y)
 UBOOT_BIN          = u-boot.ldr
 else ifeq ($(BR2_TARGET_UBOOT_FORMAT_NAND_BIN),y)