diff mbox

[v2] pkg-infra: make sure cross compiling is enabled when host == target

Message ID 1342301006-3761-1-git-send-email-arnout@mind.be
State Superseded
Headers show

Commit Message

Arnout Vandecappelle July 14, 2012, 9:23 p.m. UTC
When compiling for the same architecture and libc as the host,
GNU_TARGET_NAME and GNU_HOST_NAME are equal.  configure scripts use
these to detect cross-compilation, and will decide that we're doing
native compilation.  This may trigger running of executables,
which fail because of missing libraries in the host environment.

To solve this, set the vendor part in GNU_HOST_NAME to buildroot.

This problem exists for instance in xserver_xorg-server on x86_64.

Signed-off-by: Arnout Vandecappelle (Essensium/Mind) <arnout@mind.be>
---
v2: -buildroot- instead of -buildroot_cross-, as suggested by ThomasP.

 Makefile |    2 +-
 1 file changed, 1 insertion(+), 1 deletion(-)

Comments

Thomas Petazzoni July 14, 2012, 11:13 p.m. UTC | #1
Le Sat, 14 Jul 2012 23:23:26 +0200,
"Arnout Vandecappelle (Essensium/Mind)" <arnout@mind.be> a écrit :

> When compiling for the same architecture and libc as the host,
> GNU_TARGET_NAME and GNU_HOST_NAME are equal.  configure scripts use
> these to detect cross-compilation, and will decide that we're doing
> native compilation.  This may trigger running of executables,
> which fail because of missing libraries in the host environment.
> 
> To solve this, set the vendor part in GNU_HOST_NAME to buildroot.
> 
> This problem exists for instance in xserver_xorg-server on x86_64.

Hum, after thinking a bit more about this, why would we change
GNU_HOST_NAME? It sounds strange to include "buildroot" in the name of
the build machine tuple. Adding it to the target machine tuple would
seem much more appropriate, no?

I.e:

GNU_TARGET_NAME=$(ARCH)-unknown-linux-$(LIBC)$(ABI)

changed to:

GNU_TARGET_NAME=$(ARCH)-buildroot-linux-$(LIBC)$(ABI)

No?

Thomas
diff mbox

Patch

diff --git a/Makefile b/Makefile
index b80477f..d1c4c2b 100644
--- a/Makefile
+++ b/Makefile
@@ -200,7 +200,7 @@  unexport CXXFLAGS
 unexport GREP_OPTIONS
 unexport CONFIG_SITE
 
-GNU_HOST_NAME:=$(shell support/gnuconfig/config.guess)
+GNU_HOST_NAME:=$(shell support/gnuconfig/config.guess | sed s/-unknown-/-buildroot-/)
 
 ##############################################################
 #