diff mbox

protobuf: fix circular dependency warning

Message ID 1342212552-6567-1-git-send-email-spdawson@gmail.com
State Rejected
Headers show

Commit Message

Simon Dawson July 13, 2012, 8:49 p.m. UTC
From: Simon Dawson <spdawson@gmail.com>

The protobuf package depends on host-protobuf, which leads to a
circular dependency of host-protobuf on host-protobuf. The following
warning is output.

  make: Circular host-protobuf-depends <- host-protobuf dependency dropped.

This patch breaks the circular dependency, by explictly asserting the
dependencies of host-protobuf (currently none).

Signed-off-by: Simon Dawson <spdawson@gmail.com>
---
 package/protobuf/protobuf.mk |    1 +
 1 file changed, 1 insertion(+)

Comments

Thomas Petazzoni July 13, 2012, 8:59 p.m. UTC | #1
Le Fri, 13 Jul 2012 21:49:12 +0100,
spdawson@gmail.com a écrit :

> From: Simon Dawson <spdawson@gmail.com>
> 
> The protobuf package depends on host-protobuf, which leads to a
> circular dependency of host-protobuf on host-protobuf. The following
> warning is output.
> 
>   make: Circular host-protobuf-depends <- host-protobuf dependency dropped.
> 
> This patch breaks the circular dependency, by explictly asserting the
> dependencies of host-protobuf (currently none).
> 
> Signed-off-by: Simon Dawson <spdawson@gmail.com>

I think
http://lists.busybox.net/pipermail/buildroot/2012-July/055442.html
solves that problem in a much more generic way. Could you test this
patch and report if it solves the problem for you?

Thanks!

Thomas
Simon Dawson July 14, 2012, 9:07 a.m. UTC | #2
On 13 July 2012 21:59, Thomas Petazzoni
<thomas.petazzoni@free-electrons.com> wrote:
> I think
> http://lists.busybox.net/pipermail/buildroot/2012-July/055442.html
> solves that problem in a much more generic way. Could you test this
> patch and report if it solves the problem for you?

Hi Thomas. This generic mechanism does indeed work in the present case
(package protobuf). However, the indicated patch is only for the
gentargets package mechanism; to apply to the protobuf package, a
similar modification of pkg-autotargets.mk is required.

I'm happy to do this modification, if you think it appropriate.

Simon.
Thomas Petazzoni July 14, 2012, 10:16 a.m. UTC | #3
Le Sat, 14 Jul 2012 10:07:06 +0100,
Simon Dawson <spdawson@gmail.com> a écrit :

> Hi Thomas. This generic mechanism does indeed work in the present case
> (package protobuf). However, the indicated patch is only for the
> gentargets package mechanism; to apply to the protobuf package, a
> similar modification of pkg-autotargets.mk is required.
> 
> I'm happy to do this modification, if you think it appropriate.

Arnout, can you extend your patch to take this into account (including
pkg-autotargets and pkg-cmaketargets)? Or if you don't have the time,
tell Simon to extend your patch.

Thanks!

Thomas
diff mbox

Patch

diff --git a/package/protobuf/protobuf.mk b/package/protobuf/protobuf.mk
index f18261e..e0214ed 100644
--- a/package/protobuf/protobuf.mk
+++ b/package/protobuf/protobuf.mk
@@ -9,6 +9,7 @@  PROTOBUF_SITE = http://protobuf.googlecode.com/files/
 
 # N.B. Need to use host protoc during cross compilation.
 PROTOBUF_DEPENDENCIES = host-protobuf
+HOST_PROTOBUF_DEPENDENCIES =
 PROTOBUF_CONF_OPT = --with-protoc=$(HOST_DIR)/usr/bin/protoc
 
 PROTOBUF_INSTALL_STAGING = YES