diff mbox

cups: fix libdir handling

Message ID 1341957152-19061-1-git-send-email-arnout@mind.be
State Accepted
Commit 7655b95e27c3eebf7456a726e48b7e5448692b31
Headers show

Commit Message

Arnout Vandecappelle July 10, 2012, 9:52 p.m. UTC
Cups uses /usr/lib64 if the HOST has it, no matter if it is cross compiling
for a 32bit arch, breaking the build for stuff looking in /usr/lib.

The fix of commit edd2716c didn't work, it would just force /usr/lib64 if
the target is 64 bit.  Instead, force installation in /usr/lib regardless
of the host.

Signed-off-by: Arnout Vandecappelle (Essensium/Mind) <arnout@mind.be>

---
 package/cups/cups.mk |    2 +-
 1 file changed, 1 insertion(+), 1 deletion(-)

Comments

Peter Korsgaard Nov. 4, 2012, 11:07 a.m. UTC | #1
>>>>> "Arnout" == Arnout Vandecappelle (Essensium/Mind) <arnout@mind.be> writes:

 Arnout> Cups uses /usr/lib64 if the HOST has it, no matter if it is
 Arnout> cross compiling for a 32bit arch, breaking the build for stuff
 Arnout> looking in /usr/lib.

 Arnout> The fix of commit edd2716c didn't work, it would just force
 Arnout> /usr/lib64 if the target is 64 bit.  Instead, force
 Arnout> installation in /usr/lib regardless of the host.

 Arnout> Signed-off-by: Arnout Vandecappelle (Essensium/Mind) <arnout@mind.be>

Committed, thanks.
diff mbox

Patch

diff --git a/package/cups/cups.mk b/package/cups/cups.mk
index 6d906ec..1f88cff 100644
--- a/package/cups/cups.mk
+++ b/package/cups/cups.mk
@@ -14,7 +14,7 @@  CUPS_CONF_OPT = --without-perl \
 		--without-java \
 		--disable-gnutls \
 		--disable-gssapi \
-		--libdir=/usr/$(if $(BR2_ARCH_IS_64),lib64,lib)
+		--libdir=/usr/lib
 
 CUPS_DEPENDENCIES = $(if $(BR2_PACKAGE_ZLIB),zlib) \
 		    $(if $(BR2_PACKAGE_LIBPNG),libpng) \