diff mbox

[RFC/PATCH,4/4] linux: ensure buildroot_defconfig is writable

Message ID 1340031743-29694-5-git-send-email-ntl@pobox.com
State Changes Requested
Delegated to: Yann E. MORIN
Headers show

Commit Message

Nathan Lynch June 18, 2012, 3:02 p.m. UTC
If $(KERNEL_SOURCE_CONFIG) is read-only, the rm of
$(KERNEL_ARCH_PATH)/configs/buildroot_defconfig will prompt the user.
Make it writable and use rm -f for good measure.

Signed-off-by: Nathan Lynch <ntl@pobox.com>
---
 linux/linux.mk |    3 ++-
 1 file changed, 2 insertions(+), 1 deletion(-)
diff mbox

Patch

diff --git a/linux/linux.mk b/linux/linux.mk
index f165dda..211d054 100644
--- a/linux/linux.mk
+++ b/linux/linux.mk
@@ -138,8 +138,9 @@  endif
 
 define LINUX_CONFIGURE_CMDS
 	cp $(KERNEL_SOURCE_CONFIG) $(KERNEL_ARCH_PATH)/configs/buildroot_defconfig
+	chmod u+w $(KERNEL_ARCH_PATH)/configs/buildroot_defconfig
 	$(TARGET_MAKE_ENV) $(MAKE1) $(LINUX_MAKE_FLAGS) -C $(@D) buildroot_defconfig
-	rm $(KERNEL_ARCH_PATH)/configs/buildroot_defconfig
+	rm -f $(KERNEL_ARCH_PATH)/configs/buildroot_defconfig
 	$(if $(BR2_ARM_EABI),
 		$(call KCONFIG_ENABLE_OPT,CONFIG_AEABI,$(@D)/.config),
 		$(call KCONFIG_DISABLE_OPT,CONFIG_AEABI,$(@D)/.config))