diff mbox

monit: fix configuration error

Message ID 1339489635-11299-1-git-send-email-spdawson@gmail.com
State Accepted
Commit c5832382a18e285376e9a519e3fbfd6436e42a73
Headers show

Commit Message

Simon Dawson June 12, 2012, 8:27 a.m. UTC
From: Simon Dawson <spdawson@gmail.com>

Configuration fails for the monit package, with the following error.

  checking for SSL library directory... Not found

  Couldn't find your SSL library files.
  Use --with-ssl-lib-dir option to fix this problem or disable the
  SSL support with --without-ssl

Tweak the monit configuration command line so that openssl is found.

Signed-off-by: Simon Dawson <spdawson@gmail.com>
---
 package/monit/monit.mk |    2 +-
 1 file changed, 1 insertion(+), 1 deletion(-)

Comments

Peter Korsgaard June 16, 2012, 8:04 p.m. UTC | #1
>>>>> "spdawson" == spdawson  <spdawson@gmail.com> writes:

 spdawson> From: Simon Dawson <spdawson@gmail.com>
 spdawson> Configuration fails for the monit package, with the following error.

 spdawson>   checking for SSL library directory... Not found

 spdawson>   Couldn't find your SSL library files.
 spdawson>   Use --with-ssl-lib-dir option to fix this problem or disable the
 spdawson>   SSL support with --without-ssl

 spdawson> Tweak the monit configuration command line so that openssl is found.

Committed, thanks.
diff mbox

Patch

diff --git a/package/monit/monit.mk b/package/monit/monit.mk
index 958618d..11bc7e1 100644
--- a/package/monit/monit.mk
+++ b/package/monit/monit.mk
@@ -15,7 +15,7 @@  MONIT_CONF_OPT += \
 	--without-pam
 
 ifeq ($(BR2_PACKAGE_OPENSSL),y)
-MONIT_CONF_OPT += --with-ssl
+MONIT_CONF_OPT += --with-ssl=$(STAGING_DIR)/usr
 MONIT_DEPENDENCIES += openssl
 else
 MONIT_CONF_OPT += --without-ssl