diff mbox

beecrypt: fix build failure of C++ code with g++ 4.7

Message ID 1338658911-4807-1-git-send-email-thomas.petazzoni@free-electrons.com
State Accepted
Commit 74da2cca30852cc12c5f6e83be39e301aff74d62
Headers show

Commit Message

Thomas Petazzoni June 2, 2012, 5:41 p.m. UTC
This fixes
http://autobuild.buildroot.org/results/5c1e904b201676275465c902ba3c09951973755c/build-end.log.

Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
---
 package/beecrypt/beecrypt.mk |    7 +++++++
 1 file changed, 7 insertions(+)

Comments

Peter Korsgaard June 4, 2012, 10:20 p.m. UTC | #1
>>>>> "Thomas" == Thomas Petazzoni <thomas.petazzoni@free-electrons.com> writes:

 Thomas> This fixes
 Thomas> http://autobuild.buildroot.org/results/5c1e904b201676275465c902ba3c09951973755c/build-end.log.

Committed, thanks.
diff mbox

Patch

diff --git a/package/beecrypt/beecrypt.mk b/package/beecrypt/beecrypt.mk
index a0187ce..7642c1b 100644
--- a/package/beecrypt/beecrypt.mk
+++ b/package/beecrypt/beecrypt.mk
@@ -7,6 +7,13 @@  BEECRYPT_VERSION = 4.2.1
 BEECRYPT_SITE = http://$(BR2_SOURCEFORGE_MIRROR).dl.sourceforge.net/sourceforge/beecrypt
 BEECRYPT_AUTORECONF = YES
 BEECRYPT_INSTALL_STAGING = YES
+
+# beecrypt contains C++ code that g++ 4.7 doesn't really
+# like. Upstream does not seem to be really active, so workaround this
+# by passing -fpermissive.
+BEECRYPT_CONF_ENV = \
+	CXXFLAGS="$(TARGET_CXXFLAGS) -fpermissive"
+
 BEECRYPT_CONF_OPT = \
 		--without-java \
 		--without-python