diff mbox

collectd: fix dependencies for bind plugin

Message ID 1338647833-26267-1-git-send-email-gustavo@zacarias.com.ar
State Accepted
Commit 6457adf87b17c597761a503cfbee4923a3772ee8
Headers show

Commit Message

Gustavo Zacarias June 2, 2012, 2:37 p.m. UTC
The bind plugin requires libcurl and libxml2.
These are properly selected but never added to COLLECTD_DEPENDENCIES.
Fix that.

Signed-off-by: Gustavo Zacarias <gustavo@zacarias.com.ar>
---
 package/collectd/collectd.mk |    1 +
 1 files changed, 1 insertions(+), 0 deletions(-)

Comments

Peter Korsgaard June 5, 2012, 2:36 p.m. UTC | #1
>>>>> "Gustavo" == Gustavo Zacarias <gustavo@zacarias.com.ar> writes:

 Gustavo> The bind plugin requires libcurl and libxml2.
 Gustavo> These are properly selected but never added to COLLECTD_DEPENDENCIES.
 Gustavo> Fix that.

Committed, thanks.
diff mbox

Patch

diff --git a/package/collectd/collectd.mk b/package/collectd/collectd.mk
index 0109f77..4404509 100644
--- a/package/collectd/collectd.mk
+++ b/package/collectd/collectd.mk
@@ -87,6 +87,7 @@  COLLECTD_CONF_OPT += --with-nan-emulation --with-fp-layout=nothing \
 
 COLLECTD_DEPENDENCIES = host-pkg-config \
 	$(if $(BR2_PACKAGE_COLLECTD_APACHE),libcurl) \
+	$(if $(BR2_PACKAGE_COLLECTD_BIND),libcurl libxml2) \
 	$(if $(BR2_PACKAGE_COLLECTD_CURL),libcurl) \
 	$(if $(BR2_PACKAGE_COLLECTD_CURL_JSON),libcurl yajl) \
 	$(if $(BR2_PACKAGE_COLLECTD_CURL_XML),libcurl libxml2) \