diff mbox

[resend] stress: new package

Message ID 1335632365-12407-1-git-send-email-arnout@mind.be
State Changes Requested
Headers show

Commit Message

Arnout Vandecappelle April 28, 2012, 4:59 p.m. UTC
Signed-off-by: Arnout Vandecappelle (Essensium/Mind) <arnout@mind.be>

---
 package/Config.in        |    1 +
 package/stress/Config.in |    8 ++++++++
 package/stress/stress.mk |   13 +++++++++++++
 3 files changed, 22 insertions(+)

\ No newline at end of file

Comments

Peter Korsgaard May 1, 2012, 8:05 p.m. UTC | #1
>>>>> "Arnout" == Arnout Vandecappelle (Essensium/Mind) <arnout@mind.be> writes:

 Arnout> Signed-off-by: Arnout Vandecappelle (Essensium/Mind) <arnout@mind.be>

 Arnout> +++ b/package/stress/stress.mk
 Arnout> @@ -0,0 +1,13 @@
 Arnout> +#############################################################
 Arnout> +#
 Arnout> +# stress - a workload generator
 Arnout> +#
 Arnout> +# http://weather.ou.edu/~apw/projects/stress/
 Arnout> +#
 Arnout> +#############################################################
 Arnout> +
 Arnout> +STRESS_VERSION = 1.0.4
 Arnout> +STRESS_SITE    = http://weather.ou.edu/~apw/projects/stress
 Arnout> +STRESS_SOURCE  = stress-$(STRESS_VERSION).tar.gz

.tar.gz is default, so you could get rid of this line.

 Arnout> +
 Arnout> +$(eval $(call AUTOTARGETS))
 Arnout> \ No newline at end of file

Please add a newline after AUTOTARGETS))

But more importantly, it seem to need largefile support:

gcc -DPACKAGE_NAME=\"\" -DPACKAGE_TARNAME=\"\" -DPACKAGE_VERSION=\"\" -DPACKAGE_STRING=\"\" -DPACKAGE_BUGREPORT=\"\" -DPACKAGE=\"stress\" -DVERSION=\"1.0.4\" -DSTDC_HEADERS=1 -DHAVE_SYS_TYPES_H=1 -DHAVE_SYS_STAT_H=1 -DHAVE_STDLIB_H=1 -DHAVE_STRING_H=1 -DHAVE_MEMORY_H=1 -DHAVE_STRINGS_H=1 -DHAVE_INTTYPES_H=1 -DHAVE_STDINT_H=1 -DHAVE_UNISTD_H=1 -DHAVE_UNISTD_H=1 -DHAVE_LIBM=1 -I.    -D_FILE_OFFSET_BITS=64 -D_LARGEFILE_SOURCE -pipe -Os  -MT stress.o -MD -MP -MF .deps/stress.Tpo -c -o stress.o stress.c
In file included from /home/peko/source/buildroot/output/host/usr/arm-unknown-linux-uclibcgnueabi/sysroot/usr/include/ctype.h:27:0,
                 from stress.c:21:
/home/peko/source/buildroot/output/host/usr/arm-unknown-linux-uclibcgnueabi/sysroot/usr/include/features.h:219:5:
error: #error It appears you have defined
_FILE_OFFSET_BITS=64. Unfortunately, uClibc was built without large file
support enabled.

Care to fix and resend?
diff mbox

Patch

diff --git a/package/Config.in b/package/Config.in
index a310146..9dd2158 100644
--- a/package/Config.in
+++ b/package/Config.in
@@ -35,6 +35,7 @@  source "package/netperf/Config.in"
 source "package/oprofile/Config.in"
 source "package/rt-tests/Config.in"
 source "package/strace/Config.in"
+source "package/stress/Config.in"
 source "package/whetstone/Config.in"
 source "package/valgrind/Config.in"
 source "package/pv/Config.in"
diff --git a/package/stress/Config.in b/package/stress/Config.in
new file mode 100644
index 0000000..b092b03
--- /dev/null
+++ b/package/stress/Config.in
@@ -0,0 +1,8 @@ 
+config BR2_PACKAGE_STRESS
+	bool "stress"
+	help
+	  A deliberately simple workload generator for POSIX systems.
+	  It imposes a configurable amount of CPU, memory, I/O, and
+	  disk stress on the system.
+
+	  http://weather.ou.edu/~apw/projects/stress/
diff --git a/package/stress/stress.mk b/package/stress/stress.mk
new file mode 100644
index 0000000..a64a0d4
--- /dev/null
+++ b/package/stress/stress.mk
@@ -0,0 +1,13 @@ 
+#############################################################
+#
+# stress - a workload generator
+#
+# http://weather.ou.edu/~apw/projects/stress/
+#
+#############################################################
+
+STRESS_VERSION = 1.0.4
+STRESS_SITE    = http://weather.ou.edu/~apw/projects/stress
+STRESS_SOURCE  = stress-$(STRESS_VERSION).tar.gz
+
+$(eval $(call AUTOTARGETS))