diff mbox

pkg-download.mk: Add missing argument for DOWNLOAD_WGET

Message ID 1335344690-21404-1-git-send-email-markos.chandras@imgtec.com
State Superseded, archived
Headers show

Commit Message

Markos Chandras April 25, 2012, 9:04 a.m. UTC
Signed-off-by: Markos Chandras <markos.chandras@imgtec.com>
---
 package/pkg-download.mk |    2 +-
 1 files changed, 1 insertions(+), 1 deletions(-)

Comments

Markos Chandras April 25, 2012, 11:21 a.m. UTC | #1
On 04/25/2012 10:04 AM, Markos Chandras wrote:

> Signed-off-by: Markos Chandras <markos.chandras@imgtec.com>
> ---
>  package/pkg-download.mk |    2 +-
>  1 files changed, 1 insertions(+), 1 deletions(-)
> 
> diff --git a/package/pkg-download.mk b/package/pkg-download.mk
> index ccf819e..df63c26 100644
> --- a/package/pkg-download.mk
> +++ b/package/pkg-download.mk
> @@ -161,7 +161,7 @@ endef
>  # download fails).
>  define DOWNLOAD_WGET
>         test -e $(DL_DIR)/$(2) || \
> -       $(WGET) -O $(DL_DIR)/$(2) '$(call qstrip,$(1))' || \
> +       $(WGET) -O $(DL_DIR)/$(2) '$(call qstrip,$(1))'/$(2) || \
>         (rm -f $(DL_DIR)/$(2) ; exit 1)
>  endef
> 
> --
> 1.7.1
> 


This patch fixes the problem with the primary download mirror but breaks
the rest of the download methods. I will prepare a new patch
diff mbox

Patch

diff --git a/package/pkg-download.mk b/package/pkg-download.mk
index ccf819e..df63c26 100644
--- a/package/pkg-download.mk
+++ b/package/pkg-download.mk
@@ -161,7 +161,7 @@  endef
 # download fails).
 define DOWNLOAD_WGET
 	test -e $(DL_DIR)/$(2) || \
-	$(WGET) -O $(DL_DIR)/$(2) '$(call qstrip,$(1))' || \
+	$(WGET) -O $(DL_DIR)/$(2) '$(call qstrip,$(1))'/$(2) || \
 	(rm -f $(DL_DIR)/$(2) ; exit 1)
 endef