diff mbox

[6/6,v2] core: add a make target to check the dependencies

Message ID 00edb6450d0b45ee3c0ae850f7d3a72d5aad711f.1453651102.git.yann.morin.1998@free.fr
State Superseded
Headers show

Commit Message

Yann E. MORIN Jan. 24, 2016, 4:02 p.m. UTC
Add a make target that will checks the dependencies of all packages.
This will currently only detect circular dependencies, but more tests
can be added later if need be.

This can then be used in the autobuilders to automatically report
dependency issues.

Signed-off-by: "Yann E. MORIN" <yann.morin.1998@free.fr>
Cc: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
---
 Makefile | 4 ++++
 1 file changed, 4 insertions(+)
diff mbox

Patch

diff --git a/Makefile b/Makefile
index 20927de..0532f3b 100644
--- a/Makefile
+++ b/Makefile
@@ -733,6 +733,10 @@  graph-size:
 		--file-size-csv $(GRAPHS_DIR)/file-size-stats.csv \
 		--package-size-csv $(GRAPHS_DIR)/package-size-stats.csv
 
+check-dependencies:
+	@cd "$(CONFIG_DIR)"; \
+	$(TOPDIR)/support/scripts/graph-depends -C
+
 else # ifeq ($(BR2_HAVE_DOT_CONFIG),y)
 
 all: menuconfig