snapcraft: remove libjson-c3 stage package, it is not required
diff mbox series

Message ID 20180821192227.12849-1-colin.king@canonical.com
State Accepted
Headers show
Series
  • snapcraft: remove libjson-c3 stage package, it is not required
Related show

Commit Message

Colin King Aug. 21, 2018, 7:22 p.m. UTC
From: Colin Ian King <colin.king@canonical.com>

Removing libjson-c3 stage package fixes a snap build failure on
Xenial, it is not required, so remove it.

Fixes snap build error:
Fetched 4780 kB in 0s (0 B/s)
Failed to fetch stage packages: Error downloading packages for
part 'fwts': The package 'libjson-c3' was not found..

Fixes: a6d5fc26e93d ("snapcraft: add missing stage packages")
Signed-off-by: Colin Ian King <colin.king@canonical.com>
---
 snapcraft.yaml | 1 -
 1 file changed, 1 deletion(-)

Comments

Alex Hung Aug. 21, 2018, 10:53 p.m. UTC | #1
On 2018-08-21 12:22 PM, Colin King wrote:
> From: Colin Ian King <colin.king@canonical.com>
> 
> Removing libjson-c3 stage package fixes a snap build failure on
> Xenial, it is not required, so remove it.
> 
> Fixes snap build error:
> Fetched 4780 kB in 0s (0 B/s)
> Failed to fetch stage packages: Error downloading packages for
> part 'fwts': The package 'libjson-c3' was not found..
> 
> Fixes: a6d5fc26e93d ("snapcraft: add missing stage packages")
> Signed-off-by: Colin Ian King <colin.king@canonical.com>
> ---
>   snapcraft.yaml | 1 -
>   1 file changed, 1 deletion(-)
> 
> diff --git a/snapcraft.yaml b/snapcraft.yaml
> index 30d42b1b..37a82c4b 100644
> --- a/snapcraft.yaml
> +++ b/snapcraft.yaml
> @@ -10,7 +10,6 @@ parts:
>           source: git://kernel.ubuntu.com/hwe/fwts
>           stage-packages:
>               - libfdt1
> -            - libjson-c3
>               - libbsd0
>               - libpci3
>           build-packages:
> 

Acked-by: Alex Hung <alex.hung@canonical.com>
ivanhu Aug. 22, 2018, 2:31 a.m. UTC | #2
On 08/22/2018 03:22 AM, Colin King wrote:
> From: Colin Ian King <colin.king@canonical.com>
>
> Removing libjson-c3 stage package fixes a snap build failure on
> Xenial, it is not required, so remove it.
>
> Fixes snap build error:
> Fetched 4780 kB in 0s (0 B/s)
> Failed to fetch stage packages: Error downloading packages for
> part 'fwts': The package 'libjson-c3' was not found..
>
> Fixes: a6d5fc26e93d ("snapcraft: add missing stage packages")
> Signed-off-by: Colin Ian King <colin.king@canonical.com>
> ---
>  snapcraft.yaml | 1 -
>  1 file changed, 1 deletion(-)
>
> diff --git a/snapcraft.yaml b/snapcraft.yaml
> index 30d42b1b..37a82c4b 100644
> --- a/snapcraft.yaml
> +++ b/snapcraft.yaml
> @@ -10,7 +10,6 @@ parts:
>          source: git://kernel.ubuntu.com/hwe/fwts
>          stage-packages:
>              - libfdt1
> -            - libjson-c3
>              - libbsd0
>              - libpci3
>          build-packages:

Acked-by: Ivan Hu <ivan.hu@canonical.com>

Patch
diff mbox series

diff --git a/snapcraft.yaml b/snapcraft.yaml
index 30d42b1b..37a82c4b 100644
--- a/snapcraft.yaml
+++ b/snapcraft.yaml
@@ -10,7 +10,6 @@  parts:
         source: git://kernel.ubuntu.com/hwe/fwts
         stage-packages:
             - libfdt1
-            - libjson-c3
             - libbsd0
             - libpci3
         build-packages: