diff mbox series

[v6,11/13] tests: remove "0.15" prefix for test-qmp-cmds

Message ID 20180815133747.25032-12-peterx@redhat.com
State New
Headers show
Series monitor: enable OOB by default | expand

Commit Message

Peter Xu Aug. 15, 2018, 1:37 p.m. UTC
The "0.15" prefix seems useless.  Remove them.

Signed-off-by: Peter Xu <peterx@redhat.com>
---
 tests/test-qmp-cmds.c | 10 +++++-----
 1 file changed, 5 insertions(+), 5 deletions(-)

Comments

Thomas Huth Aug. 15, 2018, 1:48 p.m. UTC | #1
On 08/15/2018 03:37 PM, Peter Xu wrote:
> The "0.15" prefix seems useless.  Remove them.
> 
> Signed-off-by: Peter Xu <peterx@redhat.com>
> ---
>  tests/test-qmp-cmds.c | 10 +++++-----
>  1 file changed, 5 insertions(+), 5 deletions(-)
> 
> diff --git a/tests/test-qmp-cmds.c b/tests/test-qmp-cmds.c
> index ba41a6161e..989819b26d 100644
> --- a/tests/test-qmp-cmds.c
> +++ b/tests/test-qmp-cmds.c
> @@ -286,11 +286,11 @@ int main(int argc, char **argv)
>  {
>      g_test_init(&argc, &argv, NULL);
>  
> -    g_test_add_func("/0.15/dispatch_cmd", test_dispatch_cmd);
> -    g_test_add_func("/0.15/dispatch_cmd_failure", test_dispatch_cmd_failure);
> -    g_test_add_func("/0.15/dispatch_cmd_io", test_dispatch_cmd_io);
> -    g_test_add_func("/0.15/dealloc_types", test_dealloc_types);
> -    g_test_add_func("/0.15/dealloc_partial", test_dealloc_partial);
> +    g_test_add_func("/dispatch_cmd", test_dispatch_cmd);
> +    g_test_add_func("/dispatch_cmd_failure", test_dispatch_cmd_failure);
> +    g_test_add_func("/dispatch_cmd_io", test_dispatch_cmd_io);
> +    g_test_add_func("/dealloc_types", test_dealloc_types);
> +    g_test_add_func("/dealloc_partial", test_dealloc_partial);

Most other tests use a common prefix, so maybe rather replace the "0.15"
with "qmp-cmd" here? E.g.:

 g_test_add_func("/qmp-cmd/dispatch_cmd", test_dispatch_cmd);

?

 Thomas
Marc-André Lureau Aug. 15, 2018, 6:11 p.m. UTC | #2
On Wed, Aug 15, 2018 at 3:37 PM, Peter Xu <peterx@redhat.com> wrote:
> The "0.15" prefix seems useless.  Remove them.
>
> Signed-off-by: Peter Xu <peterx@redhat.com>

I sent a similar patch long ago, and it is finally queued by Markus!
:) "tests: change /0.15/* tests to /qmp/*"

> ---
>  tests/test-qmp-cmds.c | 10 +++++-----
>  1 file changed, 5 insertions(+), 5 deletions(-)
>
> diff --git a/tests/test-qmp-cmds.c b/tests/test-qmp-cmds.c
> index ba41a6161e..989819b26d 100644
> --- a/tests/test-qmp-cmds.c
> +++ b/tests/test-qmp-cmds.c
> @@ -286,11 +286,11 @@ int main(int argc, char **argv)
>  {
>      g_test_init(&argc, &argv, NULL);
>
> -    g_test_add_func("/0.15/dispatch_cmd", test_dispatch_cmd);
> -    g_test_add_func("/0.15/dispatch_cmd_failure", test_dispatch_cmd_failure);
> -    g_test_add_func("/0.15/dispatch_cmd_io", test_dispatch_cmd_io);
> -    g_test_add_func("/0.15/dealloc_types", test_dealloc_types);
> -    g_test_add_func("/0.15/dealloc_partial", test_dealloc_partial);
> +    g_test_add_func("/dispatch_cmd", test_dispatch_cmd);
> +    g_test_add_func("/dispatch_cmd_failure", test_dispatch_cmd_failure);
> +    g_test_add_func("/dispatch_cmd_io", test_dispatch_cmd_io);
> +    g_test_add_func("/dealloc_types", test_dealloc_types);
> +    g_test_add_func("/dealloc_partial", test_dealloc_partial);
>
>      test_qmp_init_marshal(&qmp_commands);
>      g_test_run();
> --
> 2.17.1
>
Peter Xu Aug. 16, 2018, 1:51 a.m. UTC | #3
On Wed, Aug 15, 2018 at 08:11:22PM +0200, Marc-André Lureau wrote:
> On Wed, Aug 15, 2018 at 3:37 PM, Peter Xu <peterx@redhat.com> wrote:
> > The "0.15" prefix seems useless.  Remove them.
> >
> > Signed-off-by: Peter Xu <peterx@redhat.com>
> 
> I sent a similar patch long ago, and it is finally queued by Markus!
> :) "tests: change /0.15/* tests to /qmp/*"

Oh! I guess I rebased to a not-the-latest master tree due to some
unknown reason...

Thanks for mentioning.  I'll drop this patch in my next post (and I'll
also modify the next patch to match the names).

Regards,
Peter Xu Aug. 16, 2018, 1:55 a.m. UTC | #4
On Wed, Aug 15, 2018 at 03:48:57PM +0200, Thomas Huth wrote:
> On 08/15/2018 03:37 PM, Peter Xu wrote:
> > The "0.15" prefix seems useless.  Remove them.
> > 
> > Signed-off-by: Peter Xu <peterx@redhat.com>
> > ---
> >  tests/test-qmp-cmds.c | 10 +++++-----
> >  1 file changed, 5 insertions(+), 5 deletions(-)
> > 
> > diff --git a/tests/test-qmp-cmds.c b/tests/test-qmp-cmds.c
> > index ba41a6161e..989819b26d 100644
> > --- a/tests/test-qmp-cmds.c
> > +++ b/tests/test-qmp-cmds.c
> > @@ -286,11 +286,11 @@ int main(int argc, char **argv)
> >  {
> >      g_test_init(&argc, &argv, NULL);
> >  
> > -    g_test_add_func("/0.15/dispatch_cmd", test_dispatch_cmd);
> > -    g_test_add_func("/0.15/dispatch_cmd_failure", test_dispatch_cmd_failure);
> > -    g_test_add_func("/0.15/dispatch_cmd_io", test_dispatch_cmd_io);
> > -    g_test_add_func("/0.15/dealloc_types", test_dealloc_types);
> > -    g_test_add_func("/0.15/dealloc_partial", test_dealloc_partial);
> > +    g_test_add_func("/dispatch_cmd", test_dispatch_cmd);
> > +    g_test_add_func("/dispatch_cmd_failure", test_dispatch_cmd_failure);
> > +    g_test_add_func("/dispatch_cmd_io", test_dispatch_cmd_io);
> > +    g_test_add_func("/dealloc_types", test_dealloc_types);
> > +    g_test_add_func("/dealloc_partial", test_dealloc_partial);
> 
> Most other tests use a common prefix, so maybe rather replace the "0.15"
> with "qmp-cmd" here? E.g.:
> 
>  g_test_add_func("/qmp-cmd/dispatch_cmd", test_dispatch_cmd);
> 
> ?

I'll drop this patch due to a dup in master.  That one has "/qmp"
prefix.  Thanks Thomas.
Markus Armbruster Aug. 16, 2018, 7:20 a.m. UTC | #5
Peter Xu <peterx@redhat.com> writes:

> On Wed, Aug 15, 2018 at 08:11:22PM +0200, Marc-André Lureau wrote:
>> On Wed, Aug 15, 2018 at 3:37 PM, Peter Xu <peterx@redhat.com> wrote:
>> > The "0.15" prefix seems useless.  Remove them.
>> >
>> > Signed-off-by: Peter Xu <peterx@redhat.com>
>> 
>> I sent a similar patch long ago, and it is finally queued by Markus!
>> :) "tests: change /0.15/* tests to /qmp/*"
>
> Oh! I guess I rebased to a not-the-latest master tree due to some
> unknown reason...

I think you simply sent your patch before my pull request went through.

> Thanks for mentioning.  I'll drop this patch in my next post (and I'll
> also modify the next patch to match the names).

Thanks!
diff mbox series

Patch

diff --git a/tests/test-qmp-cmds.c b/tests/test-qmp-cmds.c
index ba41a6161e..989819b26d 100644
--- a/tests/test-qmp-cmds.c
+++ b/tests/test-qmp-cmds.c
@@ -286,11 +286,11 @@  int main(int argc, char **argv)
 {
     g_test_init(&argc, &argv, NULL);
 
-    g_test_add_func("/0.15/dispatch_cmd", test_dispatch_cmd);
-    g_test_add_func("/0.15/dispatch_cmd_failure", test_dispatch_cmd_failure);
-    g_test_add_func("/0.15/dispatch_cmd_io", test_dispatch_cmd_io);
-    g_test_add_func("/0.15/dealloc_types", test_dealloc_types);
-    g_test_add_func("/0.15/dealloc_partial", test_dealloc_partial);
+    g_test_add_func("/dispatch_cmd", test_dispatch_cmd);
+    g_test_add_func("/dispatch_cmd_failure", test_dispatch_cmd_failure);
+    g_test_add_func("/dispatch_cmd_io", test_dispatch_cmd_io);
+    g_test_add_func("/dealloc_types", test_dealloc_types);
+    g_test_add_func("/dealloc_partial", test_dealloc_partial);
 
     test_qmp_init_marshal(&qmp_commands);
     g_test_run();