qemu-doc: mark ppc/prep machine as deprecated

Message ID 20180810224645.10659-1-hpoussin@reactos.org
State New
Headers show
Series
  • qemu-doc: mark ppc/prep machine as deprecated
Related show

Commit Message

Hervé Poussineau Aug. 10, 2018, 10:46 p.m.
40p machine type should be used instead.

Signed-off-by: Hervé Poussineau <hpoussin@reactos.org>
---
 qemu-deprecated.texi | 6 ++++++
 1 file changed, 6 insertions(+)

Comments

Mark Cave-Ayland Aug. 11, 2018, 6:17 a.m. | #1
On 10/08/18 23:46, Hervé Poussineau wrote:

> 40p machine type should be used instead.
> 
> Signed-off-by: Hervé Poussineau <hpoussin@reactos.org>
> ---
>  qemu-deprecated.texi | 6 ++++++
>  1 file changed, 6 insertions(+)
> 
> diff --git a/qemu-deprecated.texi b/qemu-deprecated.texi
> index 9920a85adc..9c7ff3fe2d 100644
> --- a/qemu-deprecated.texi
> +++ b/qemu-deprecated.texi
> @@ -218,6 +218,12 @@ support page sizes < 4096 any longer.
>  These machine types are very old and likely can not be used for live migration
>  from old QEMU versions anymore. A newer machine type should be used instead.
>  
> +@subsection prep (PowerPC) (since 3.1)
> +
> +This machine type uses an unmaintained firmware, broken in lots of ways,
> +and unable to start post-2004 operating systems. 40p machine type should be
> +used instead.
> +
>  @section Device options
>  
>  @subsection Block device options

Acked-by: Mark Cave-Ayland <mark.cave-ayland@ilande.co.uk>


ATB,

Mark.
David Gibson Aug. 13, 2018, 1:57 a.m. | #2
On Sat, Aug 11, 2018 at 12:46:45AM +0200, Hervé Poussineau wrote:
> 40p machine type should be used instead.
> 
> Signed-off-by: Hervé Poussineau <hpoussin@reactos.org>
> ---
>  qemu-deprecated.texi | 6 ++++++
>  1 file changed, 6 insertions(+)
> 
> diff --git a/qemu-deprecated.texi b/qemu-deprecated.texi
> index 9920a85adc..9c7ff3fe2d 100644
> --- a/qemu-deprecated.texi
> +++ b/qemu-deprecated.texi
> @@ -218,6 +218,12 @@ support page sizes < 4096 any longer.
>  These machine types are very old and likely can not be used for live migration
>  from old QEMU versions anymore. A newer machine type should be used instead.
>  
> +@subsection prep (PowerPC) (since 3.1)
> +
> +This machine type uses an unmaintained firmware, broken in lots of ways,
> +and unable to start post-2004 operating systems. 40p machine type should be
> +used instead.
> +
>  @section Device options
>  
>  @subsection Block device options

Applied to ppc-for-3.1, thanks.

Patch

diff --git a/qemu-deprecated.texi b/qemu-deprecated.texi
index 9920a85adc..9c7ff3fe2d 100644
--- a/qemu-deprecated.texi
+++ b/qemu-deprecated.texi
@@ -218,6 +218,12 @@  support page sizes < 4096 any longer.
 These machine types are very old and likely can not be used for live migration
 from old QEMU versions anymore. A newer machine type should be used instead.
 
+@subsection prep (PowerPC) (since 3.1)
+
+This machine type uses an unmaintained firmware, broken in lots of ways,
+and unable to start post-2004 operating systems. 40p machine type should be
+used instead.
+
 @section Device options
 
 @subsection Block device options