[1/3] docs/manual: add flex+bison to pre-requisites

Message ID e46b168daba5486329166279765dcbdb51bd3787.1533333972.git.yann.morin.1998@free.fr
State Rejected
Headers show
Series
  • [1/3] docs/manual: add flex+bison to pre-requisites
Related show

Commit Message

Yann E. MORIN Aug. 3, 2018, 10:06 p.m.
Signed-off-by: "Yann E. MORIN" <yann.morin.1998@free.fr>
Cc: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
Cc: Arnout Vandecappelle <arnout@mind.be>
Cc: Peter Korsgaard <peter@korsgaard.com>
---
 docs/manual/prerequisite.txt | 3 ++-
 1 file changed, 2 insertions(+), 1 deletion(-)

Comments

Baruch Siach Aug. 5, 2018, 4:25 a.m. | #1
Hi Yann,

On Sat, Aug 04, 2018 at 12:06:18AM +0200, Yann E. MORIN wrote:
> Signed-off-by: "Yann E. MORIN" <yann.morin.1998@free.fr>
> Cc: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
> Cc: Arnout Vandecappelle <arnout@mind.be>
> Cc: Peter Korsgaard <peter@korsgaard.com>
> ---
>  docs/manual/prerequisite.txt | 3 ++-
>  1 file changed, 2 insertions(+), 1 deletion(-)
> 
> diff --git a/docs/manual/prerequisite.txt b/docs/manual/prerequisite.txt
> index 110fab41fd..0867e4d619 100644
> --- a/docs/manual/prerequisite.txt
> +++ b/docs/manual/prerequisite.txt
> @@ -24,7 +24,8 @@ between distributions).
>  ** +binutils+
>  ** +build-essential+ (only for Debian based systems)
>  ** +gcc+ (version 2.95 or any later)
> -** `g++` (version 2.95 or any later)

Is this removal intended?

BTW, is version 2.95 realistic? Is it actually possible to build a reasonable 
Buildroot config even with host gcc 3.x?

> +** `bison`
> +** `flex`
>  ** +bash+
>  ** +patch+
>  ** +gzip+

baruch
Yann E. MORIN Aug. 5, 2018, 6:54 a.m. | #2
Baruch, All,

On 2018-08-05 07:25 +0300, Baruch Siach spake thusly:
> On Sat, Aug 04, 2018 at 12:06:18AM +0200, Yann E. MORIN wrote:
> > Signed-off-by: "Yann E. MORIN" <yann.morin.1998@free.fr>
> > Cc: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
> > Cc: Arnout Vandecappelle <arnout@mind.be>
> > Cc: Peter Korsgaard <peter@korsgaard.com>
> > ---
> >  docs/manual/prerequisite.txt | 3 ++-
> >  1 file changed, 2 insertions(+), 1 deletion(-)
> > 
> > diff --git a/docs/manual/prerequisite.txt b/docs/manual/prerequisite.txt
> > index 110fab41fd..0867e4d619 100644
> > --- a/docs/manual/prerequisite.txt
> > +++ b/docs/manual/prerequisite.txt
> > @@ -24,7 +24,8 @@ between distributions).
> >  ** +binutils+
> >  ** +build-essential+ (only for Debian based systems)
> >  ** +gcc+ (version 2.95 or any later)
> > -** `g++` (version 2.95 or any later)
> 
> Is this removal intended?

Nope, that was not intentional.

> BTW, is version 2.95 realistic? Is it actually possible to build a reasonable 
> Buildroot config even with host gcc 3.x?

Probably not, but that is a brand other topic...

Thanks! :-)

Regards,
Yann E. MORIN.

> > +** `bison`
> > +** `flex`
> >  ** +bash+
> >  ** +patch+
> >  ** +gzip+
> 
> baruch
> 
> -- 
>      http://baruch.siach.name/blog/                  ~. .~   Tk Open Systems
> =}------------------------------------------------ooO--U--Ooo------------{=
>    - baruch@tkos.co.il - tel: +972.2.679.5364, http://www.tkos.co.il -
Thomas Petazzoni Aug. 5, 2018, 9:58 a.m. | #3
Hello,

On Sun, 5 Aug 2018 07:25:52 +0300, Baruch Siach wrote:

> BTW, is version 2.95 realistic? Is it actually possible to build a reasonable 
> Buildroot config even with host gcc 3.x?

Hollis Blanchard recently started an autobuilder on RHEL6.5, which uses
host gcc 4.4, and sent some fixes for build issues encountered with
host gcc 4.4.

So, since this is the oldest gcc version that we're testing, I would
suggest that we document this version as the minimum gcc version.

Best regards,

Thomas

Patch

diff --git a/docs/manual/prerequisite.txt b/docs/manual/prerequisite.txt
index 110fab41fd..0867e4d619 100644
--- a/docs/manual/prerequisite.txt
+++ b/docs/manual/prerequisite.txt
@@ -24,7 +24,8 @@  between distributions).
 ** +binutils+
 ** +build-essential+ (only for Debian based systems)
 ** +gcc+ (version 2.95 or any later)
-** `g++` (version 2.95 or any later)
+** `bison`
+** `flex`
 ** +bash+
 ** +patch+
 ** +gzip+