[linux-kvm-b,1/2] UBUNTU: [Config]: enable CONFIG_SECURITY_PERF_EVENTS_RESTRICT

Message ID 20180612105315.1954-2-po-hsu.lin@canonical.com
State New
Headers show
Series
  • Enable CONFIG_SECURITY_PERF_EVENTS_RESTRICT and CONFIG_FORTIFY_SOURCE
Related show

Commit Message

Po-Hsu Lin June 12, 2018, 10:53 a.m.
BugLink: https://bugs.launchpad.net/bugs/1766780

Enable the CONFIG_SECURITY_PERF_EVENTS_RESTRICT, which is required by the
kernel security testsuite.

Signed-off-by: Po-Hsu Lin <po-hsu.lin@canonical.com>
---
 debian.kvm/config/config.common.ubuntu | 2 +-
 1 file changed, 1 insertion(+), 1 deletion(-)

Patch

diff --git a/debian.kvm/config/config.common.ubuntu b/debian.kvm/config/config.common.ubuntu
index abb67e4..d4fe1a2 100644
--- a/debian.kvm/config/config.common.ubuntu
+++ b/debian.kvm/config/config.common.ubuntu
@@ -2058,7 +2058,7 @@  CONFIG_SECURITY_DEFAULT_DISPLAY_NAME="apparmor"
 CONFIG_SECURITY_NETWORK=y
 CONFIG_SECURITY_NETWORK_XFRM=y
 CONFIG_SECURITY_PATH=y
-# CONFIG_SECURITY_PERF_EVENTS_RESTRICT is not set
+CONFIG_SECURITY_PERF_EVENTS_RESTRICT=y
 CONFIG_SECURITY_SELINUX=y
 CONFIG_SECURITY_SELINUX_AVC_STATS=y
 CONFIG_SECURITY_SELINUX_BOOTPARAM=y