[linux-kvm-b,2/2] UBUNTU: [Config]: enable CONFIG_FORTIFY_SOURCE

Message ID 20180612105315.1954-3-po-hsu.lin@canonical.com
State New
Headers show
Series
  • Enable CONFIG_SECURITY_PERF_EVENTS_RESTRICT and CONFIG_FORTIFY_SOURCE
Related show

Commit Message

Po-Hsu Lin June 12, 2018, 10:53 a.m.
BugLink: https://bugs.launchpad.net/bugs/1766774

Enable the CONFIG_FORTIFY_SOURCE, which is required by the kernel security
testsuite.

Signed-off-by: Po-Hsu Lin <po-hsu.lin@canonical.com>
---
 debian.kvm/config/config.common.ubuntu | 2 +-
 1 file changed, 1 insertion(+), 1 deletion(-)

Patch

diff --git a/debian.kvm/config/config.common.ubuntu b/debian.kvm/config/config.common.ubuntu
index d4fe1a2..10cf241 100644
--- a/debian.kvm/config/config.common.ubuntu
+++ b/debian.kvm/config/config.common.ubuntu
@@ -723,7 +723,7 @@  CONFIG_FILE_LOCKING=y
 # CONFIG_FIRMWARE_MEMMAP is not set
 CONFIG_FIX_EARLYCON_MEM=y
 # CONFIG_FMC is not set
-# CONFIG_FORTIFY_SOURCE is not set
+CONFIG_FORTIFY_SOURCE=y
 # CONFIG_FPGA is not set
 CONFIG_FRAME_POINTER=y
 CONFIG_FRAME_WARN=2048