[OpenWrt-Devel] ramips: change LED trigger

Message ID 20180610223738.17152-1-mail@david-bauer.net
State Accepted
Delegated to: John Crispin
Headers show
Series
  • [OpenWrt-Devel] ramips: change LED trigger
Related show

Commit Message

David Bauer June 10, 2018, 10:37 p.m.
This commit changes the trigger for the WiFi-LED from netdev to the
wireless PHY device.

With this change, the LEDs illuminate, even when the wireless interface
is not named wifi{0,1}.

This change is (for now) applied only to MT7628 devices from TP-Link, as
we had the possibility to test this change against two of those devices,
namely a TL-WR841 v13 and a Archer C50 v3.

Signed-off-by: David Bauer <mail@david-bauer.net>
---
 target/linux/ramips/base-files/etc/board.d/01_leds | 8 ++++----
 1 file changed, 4 insertions(+), 4 deletions(-)

Patch

diff --git a/target/linux/ramips/base-files/etc/board.d/01_leds b/target/linux/ramips/base-files/etc/board.d/01_leds
index ae5ac77b5e..73e3f22418 100755
--- a/target/linux/ramips/base-files/etc/board.d/01_leds
+++ b/target/linux/ramips/base-files/etc/board.d/01_leds
@@ -384,12 +384,12 @@  tiny-ac)
 	set_usb_led "$boardname:green:usb"
 	;;
 tl-wr840n-v4)
-	set_wifi_led "$boardname:green:wlan"
+	ucidef_set_led_wlan "wlan2g" "wlan2g" "$boardname:green:wlan" "phy0tpt"
 	ucidef_set_led_switch "lan" "lan" "$boardname:green:lan" "switch0" "0x1e"
 	ucidef_set_led_switch "wan" "wan" "$boardname:green:wan" "switch0" "0x01"
 	;;
 tl-wr841n-v13)
-	set_wifi_led "$boardname:green:wlan"
+	ucidef_set_led_wlan "wlan2g" "wlan2g" "$boardname:green:wlan" "phy0tpt"
 	ucidef_set_led_switch "lan1" "lan1" "$boardname:green:lan1" "switch0" "0x2"
 	ucidef_set_led_switch "lan2" "lan2" "$boardname:green:lan2" "switch0" "0x4"
 	ucidef_set_led_switch "lan3" "lan3" "$boardname:green:lan3" "switch0" "0x8"
@@ -415,13 +415,13 @@  tplink,c50-v3)
 	;;
 tplink,tl-mr3420-v5)
 	set_usb_led "$boardname:green:usb"
-	set_wifi_led "$boardname:green:wlan"
+	ucidef_set_led_wlan "wlan2g" "wlan2g" "$boardname:green:wlan" "phy0tpt"
 	ucidef_set_led_switch "lan" "lan" "$boardname:green:lan" "switch0" "0x1e"
 	ucidef_set_led_switch "wan" "wan" "$boardname:green:wan" "switch0" "0x01"
 	;;
 tplink,tl-wr902ac-v3)
 	set_usb_led "$boardname:green:usb"
-	ucidef_set_led_netdev "wlan2g" "wlan2g" "$boardname:green:wlan" "wlan0"
+	ucidef_set_led_wlan "wlan2g" "wlan2g" "$boardname:green:wlan" "phy0tpt"
 	ucidef_set_led_switch "lan" "lan" "$boardname:green:lan" "switch0" "0x10"
 	;;
 u25awf-h1)