[1/1] libkcapi: depends on BR2_TOOLCHAIN_HAS_SYNC_4

Message ID 20180515184138.21923-1-fontaine.fabrice@gmail.com
State Accepted
Headers show
Series
  • [1/1] libkcapi: depends on BR2_TOOLCHAIN_HAS_SYNC_4
Related show

Commit Message

Fabrice Fontaine May 15, 2018, 6:41 p.m.
Since commit
https://github.com/smuellerDD/libkcapi/commit/4d0a5c235536b5f679e6a9b0c847f56c9cfc3835,
libkcapi uses __sync_add_and_fetch_4 and __sync_sub_and_fetch_4

Fixes:
 - http://autobuild.buildroot.net/results/de5e136ea433633d836bff1d2ac1d3b461391b83

Signed-off-by: Fabrice Fontaine <fontaine.fabrice@gmail.com>
---
 package/libkcapi/Config.in | 1 +
 1 file changed, 1 insertion(+)

Comments

Thomas Petazzoni May 17, 2018, 8:22 p.m. | #1
Hello,

On Tue, 15 May 2018 20:41:38 +0200, Fabrice Fontaine wrote:
> Since commit
> https://github.com/smuellerDD/libkcapi/commit/4d0a5c235536b5f679e6a9b0c847f56c9cfc3835,
> libkcapi uses __sync_add_and_fetch_4 and __sync_sub_and_fetch_4
> 
> Fixes:
>  - http://autobuild.buildroot.net/results/de5e136ea433633d836bff1d2ac1d3b461391b83
> 
> Signed-off-by: Fabrice Fontaine <fontaine.fabrice@gmail.com>
> ---
>  package/libkcapi/Config.in | 1 +
>  1 file changed, 1 insertion(+)

Applied to master, thanks.

Thomas

Patch

diff --git a/package/libkcapi/Config.in b/package/libkcapi/Config.in
index 7397cfe800..1dbcdc381b 100644
--- a/package/libkcapi/Config.in
+++ b/package/libkcapi/Config.in
@@ -1,5 +1,6 @@ 
 config BR2_PACKAGE_LIBKCAPI
 	bool "libkcapi"
+	depends on BR2_TOOLCHAIN_HAS_SYNC_4
 	help
 	  Linux Kernel Crypto API userspace interface library