[v2,1/2] libgdiplus: fix license
diff mbox series

Message ID 20180502183336.13568-1-fontaine.fabrice@gmail.com
State Deferred
Delegated to: Arnout Vandecappelle
Headers show
Series
  • [v2,1/2] libgdiplus: fix license
Related show

Commit Message

Fabrice Fontaine May 2, 2018, 6:33 p.m. UTC
libgdiplus is licensed under LGPL-2.1 or MPL-1.1 and not MIT, see:
http://patchwork.ozlabs.org/patch/906830

Signed-off-by: Fabrice Fontaine <fontaine.fabrice@gmail.com>
---
Changes v1 -> v2 (after review of Thomas Petazzoni and Sergio Prado):
 - Fix license from MIT to LGPL-2.1 or MPL-1.1 (in a separate patch)

 package/libgdiplus/libgdiplus.mk | 9 ++-------
 1 file changed, 2 insertions(+), 7 deletions(-)

Patch
diff mbox series

diff --git a/package/libgdiplus/libgdiplus.mk b/package/libgdiplus/libgdiplus.mk
index eb1858574d..52032d4f07 100644
--- a/package/libgdiplus/libgdiplus.mk
+++ b/package/libgdiplus/libgdiplus.mk
@@ -6,13 +6,8 @@ 
 
 LIBGDIPLUS_VERSION = 5.4
 LIBGDIPLUS_SITE = $(call github,mono,libgdiplus,$(LIBGDIPLUS_VERSION))
-
-# Although there is a LICENSE file thas specifies LGPL or MPL-1.1,
-# looks like it is incorrect. The actual source files specify that
-# they're licensed under MIT, and so does the COPYING file (and they
-# all predate the addition of the LICENSE file).
-LIBGDIPLUS_LICENSE = MIT
-LIBGDIPLUS_LICENSE_FILES = COPYING src/carbon-private.h
+LIBGDIPLUS_LICENSE = LGPL-2.1 or MPL-1.1
+LIBGDIPLUS_LICENSE_FILES = LICENSE
 
 LIBGDIPLUS_INSTALL_STAGING = YES