[ovs-dev,7/8] acinclude: Enable building for Linux kernel 4.15

Message ID 1518650290-31536-8-git-send-email-gvrose8192@gmail.com
State Accepted
Headers show
Series
  • Linux upstream kernel backports and updates
Related show

Commit Message

Gregory Rose Feb. 14, 2018, 11:18 p.m.
Signed-off-by: Greg Rose <gvrose8192@gmail.com>
---
 acinclude.m4 | 4 ++--
 1 file changed, 2 insertions(+), 2 deletions(-)

Patch

diff --git a/acinclude.m4 b/acinclude.m4
index c8cfbe1..b5f62cc 100644
--- a/acinclude.m4
+++ b/acinclude.m4
@@ -151,10 +151,10 @@  AC_DEFUN([OVS_CHECK_LINUX], [
     AC_MSG_RESULT([$kversion])
 
     if test "$version" -ge 4; then
-       if test "$version" = 4 && test "$patchlevel" -le 14; then
+       if test "$version" = 4 && test "$patchlevel" -le 15; then
           : # Linux 4.x
        else
-          AC_ERROR([Linux kernel in $KBUILD is version $kversion, but version newer than 4.14.x is not supported (please refer to the FAQ for advice)])
+          AC_ERROR([Linux kernel in $KBUILD is version $kversion, but version newer than 4.15.x is not supported (please refer to the FAQ for advice)])
        fi
     elif test "$version" = 3 && test "$patchlevel" -ge 10; then
        : # Linux 3.x