UBUNTU: SAUCE: ath10k: change QCA9377 IRAM back to 9

Message ID 1518145645-2026-2-git-send-email-acelan.kao@canonical.com
State New
Headers show
Series
  • UBUNTU: SAUCE: ath10k: change QCA9377 IRAM back to 9
Related show

Commit Message

AceLan Kao Feb. 9, 2018, 3:07 a.m.
BugLink: https://bugs.launchpad.net/bugs/1748345

The patch is for downloading QCA9377 new firmware which is compliant
with RED 2.1.1 to QCA9377 IRAM bank 9. Because this new firmware is
bigger, IRAM bank 4 space is not enough, so we need to change to bank 9.

Signed-off-by: AceLan Kao <acelan.kao@canonical.com>
---
 drivers/net/wireless/ath/ath10k/pci.c | 2 +-
 1 file changed, 1 insertion(+), 1 deletion(-)

Patch

diff --git a/drivers/net/wireless/ath/ath10k/pci.c b/drivers/net/wireless/ath/ath10k/pci.c
index 7ebfc40..619c115 100644
--- a/drivers/net/wireless/ath/ath10k/pci.c
+++ b/drivers/net/wireless/ath/ath10k/pci.c
@@ -1991,7 +1991,7 @@  static int ath10k_pci_get_num_banks(struct ath10k *ar)
 		}
 		break;
 	case QCA9377_1_0_DEVICE_ID:
-		return 4;
+		return 9;
 	}
 
 	ath10k_warn(ar, "unknown number of banks, assuming 1\n");