[v2,4/5] isa: Remove ISA_BUS_API selection for ISA_BUS

Message ID bc33320887f448b772004e7c5d97322abb8cae0b.1514578085.git.vilhelm.gray@gmail.com
State New
Headers show
Series
  • Change ISA_BUS_API dependency to selection
Related show

Commit Message

William Breathitt Gray Dec. 29, 2017, 8:14 p.m.
ISA_BUS_API is selected by drivers themselves when necessary. The
ISA_BUS Kconfig option is now simply a mask for true ISA device drivers
and relevant configuration. For now, the ISA_BUS Kconfig option is only
available for X86, but may be added for other arch builds in the future
if the need arises.

Signed-off-by: William Breathitt Gray <vilhelm.gray@gmail.com>
---
 arch/x86/Kconfig | 10 ++++++----
 1 file changed, 6 insertions(+), 4 deletions(-)

Comments

Linus Walleij Feb. 22, 2018, 3:18 p.m. | #1
On Fri, Dec 29, 2017 at 9:14 PM, William Breathitt Gray
<vilhelm.gray@gmail.com> wrote:

> ISA_BUS_API is selected by drivers themselves when necessary. The
> ISA_BUS Kconfig option is now simply a mask for true ISA device drivers
> and relevant configuration. For now, the ISA_BUS Kconfig option is only
> available for X86, but may be added for other arch builds in the future
> if the need arises.
>
> Signed-off-by: William Breathitt Gray <vilhelm.gray@gmail.com>

Patch applied to the GPIO tree for v4.17.

I'd like to have some ACK from some x86 maintainer for this
so it makes me a bit nervous.

Yet again the patch has been sitting since december with no
comments so...

Yours,
Linus Walleij
--
To unsubscribe from this list: send the line "unsubscribe linux-gpio" in
the body of a message to majordomo@vger.kernel.org
More majordomo info at  http://vger.kernel.org/majordomo-info.html

Patch

diff --git a/arch/x86/Kconfig b/arch/x86/Kconfig
index 8eed3f94bfc7..5478c5beb302 100644
--- a/arch/x86/Kconfig
+++ b/arch/x86/Kconfig
@@ -2608,11 +2608,13 @@  config PCI_CNB20LE_QUIRK
 source "drivers/pci/Kconfig"
 
 config ISA_BUS
-	bool "ISA-style bus support on modern systems" if EXPERT
-	select ISA_BUS_API
+	bool "ISA bus support on modern systems" if EXPERT
 	help
-	  Enables ISA-style drivers on modern systems. This is necessary to
-	  support PC/104 devices on X86_64 platforms.
+	  Expose ISA bus device drivers and options available for selection and
+	  configuration. Enable this option if your target machine has an ISA
+	  bus. ISA is an older system, displaced by PCI and newer bus
+	  architectures -- if your target machine is modern, it probably does
+	  not have an ISA bus.
 
 	  If unsure, say N.