[v9,5/8] libssh2: add host variant

Message ID 20171228155146.18193-6-eric.le.bihan.dev@free.fr
State Superseded
Headers show
Series
  • Add support for the Rust programming
Related show

Commit Message

Eric Le Bihan Dec. 28, 2017, 3:51 p.m.
Allow build of host variant of libssh2, which depends on host-openssl.

Signed-off-by: Eric Le Bihan <eric.le.bihan.dev@free.fr>
---
 package/libssh2/libssh2.mk | 6 ++++++
 1 file changed, 6 insertions(+)

Comments

Thomas Petazzoni Dec. 28, 2017, 9:11 p.m. | #1
Hello,

On Thu, 28 Dec 2017 16:51:43 +0100, Eric Le Bihan wrote:
> Allow build of host variant of libssh2, which depends on host-openssl.
> 
> Signed-off-by: Eric Le Bihan <eric.le.bihan.dev@free.fr>

Reviewed-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>

Long-term, it would be nice to have Config.in options for host
packages, so that we don't forcefully build openssl support in
host-libssh2, but since you're the only user for now, that's fine.

Thomas

Patch

diff --git a/package/libssh2/libssh2.mk b/package/libssh2/libssh2.mk
index 18e772c722..c5b0bd855e 100644
--- a/package/libssh2/libssh2.mk
+++ b/package/libssh2/libssh2.mk
@@ -40,4 +40,10 @@  else
 LIBSSH2_CONF_OPTS += --without-libz
 endif
 
+HOST_LIBSSH2_DEPENDENCIES += host-openssl
+HOST_LIBSSH2_CONF_OPTS += --with-openssl \
+	--with-libssl-prefix=$(HOST_DIR)/usr \
+	--without-libgcrypt
+
 $(eval $(autotools-package))
+$(eval $(host-autotools-package))