Patchwork Add -lpwl to ppllibs.

login
register
mail settings
Submitter Sebastian Pop
Date March 2, 2011, 2:48 p.m.
Message ID <AANLkTika+Vp91zw6VGLbhieM6_u1LVb50dOibvC2kWGh@mail.gmail.com>
Download mbox | patch
Permalink /patch/85088/
State New
Headers show

Comments

Sebastian Pop - March 2, 2011, 2:48 p.m.
On Wed, Mar 2, 2011 at 06:20, Richard Guenther
<richard.guenther@gmail.com> wrote:
> As you can see from the link line it doesn't link ppl at all.  ppllibs is empty
> for me.
>
> Please revert or fix ASAP.

Does the attached patch fix the problem you are seeing?

Thanks,
Sebastian
Richard Guenther - March 2, 2011, 3:01 p.m.
On Wed, Mar 2, 2011 at 3:48 PM, Sebastian Pop <sebpop@gmail.com> wrote:
> On Wed, Mar 2, 2011 at 06:20, Richard Guenther
> <richard.guenther@gmail.com> wrote:
>> As you can see from the link line it doesn't link ppl at all.  ppllibs is empty
>> for me.
>>
>> Please revert or fix ASAP.
>
> Does the attached patch fix the problem you are seeing?

It seems to work for me (bootstrap is in stage2, HAVE_cloog is 1).

Richard.
Sebastian Pop - March 2, 2011, 3:07 p.m.
On Wed, Mar 2, 2011 at 09:01, Richard Guenther
<richard.guenther@gmail.com> wrote:
> On Wed, Mar 2, 2011 at 3:48 PM, Sebastian Pop <sebpop@gmail.com> wrote:
>> On Wed, Mar 2, 2011 at 06:20, Richard Guenther
>> <richard.guenther@gmail.com> wrote:
>>> As you can see from the link line it doesn't link ppl at all.  ppllibs is empty
>>> for me.
>>>
>>> Please revert or fix ASAP.
>>
>> Does the attached patch fix the problem you are seeing?
>
> It seems to work for me (bootstrap is in stage2, HAVE_cloog is 1).

Ok, thanks for checking.

So my theory is that you configured with "--with-ppl" with no arguments,
that sets the variable $with_ppl to the empty string, and so "x$with_ppl"
is not equal to "xyes" in that case.

Sebastian
Richard Guenther - March 2, 2011, 3:08 p.m.
On Wed, Mar 2, 2011 at 4:07 PM, Sebastian Pop <sebpop@gmail.com> wrote:
> On Wed, Mar 2, 2011 at 09:01, Richard Guenther
> <richard.guenther@gmail.com> wrote:
>> On Wed, Mar 2, 2011 at 3:48 PM, Sebastian Pop <sebpop@gmail.com> wrote:
>>> On Wed, Mar 2, 2011 at 06:20, Richard Guenther
>>> <richard.guenther@gmail.com> wrote:
>>>> As you can see from the link line it doesn't link ppl at all.  ppllibs is empty
>>>> for me.
>>>>
>>>> Please revert or fix ASAP.
>>>
>>> Does the attached patch fix the problem you are seeing?
>>
>> It seems to work for me (bootstrap is in stage2, HAVE_cloog is 1).
>
> Ok, thanks for checking.
>
> So my theory is that you configured with "--with-ppl" with no arguments,
> that sets the variable $with_ppl to the empty string, and so "x$with_ppl"
> is not equal to "xyes" in that case.

No, I configured with just ./configure --enable-languages=c

Richard.

> Sebastian
>
Paolo Carlini - March 2, 2011, 3:15 p.m.
On 03/02/2011 04:01 PM, Richard Guenther wrote:
> It seems to work for me
>   
Likewise, with my usual simple configure line including only
--enable-cloog-backend=isl beyond trivial things.

Paolo.

Patch

From 05223494274bc509fddf4f2546f50e4294c9537f Mon Sep 17 00:00:00 2001
From: Sebastian Pop <sebpop@gmail.com>
Date: Wed, 2 Mar 2011 08:47:36 -0600
Subject: [PATCH] Fix configure problem.

---
 configure    |    2 +-
 configure.ac |    2 +-
 2 files changed, 2 insertions(+), 2 deletions(-)

diff --git a/configure b/configure
index 997282f..5e97d0f 100755
--- a/configure
+++ b/configure
@@ -5723,7 +5723,7 @@  if test x"$with_ppl$with_ppl_include$with_ppl_lib" = x && test -d ${srcdir}/ppl;
   with_ppl=yes
 fi
 
-if test "x$with_ppl" = xyes; then
+if test "x$with_ppl" != xno; then
   if test "x$pwllib" = x; then
     saved_LDFLAGS="$LDFLAGS"
     LDFLAGS="$LDFLAGS $ppllibs"
diff --git a/configure.ac b/configure.ac
index 4fb29c0..233ce0a 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1675,7 +1675,7 @@  if test x"$with_ppl$with_ppl_include$with_ppl_lib" = x && test -d ${srcdir}/ppl;
   with_ppl=yes
 fi
 
-if test "x$with_ppl" = xyes; then
+if test "x$with_ppl" != xno; then
   if test "x$pwllib" = x; then
     saved_LDFLAGS="$LDFLAGS"
     LDFLAGS="$LDFLAGS $ppllibs"
-- 
1.7.1