diff mbox series

[U-Boot,v2,1/3] ae3xx: timer: Rename AE3XX to ATCPIT100

Message ID 1511749982-8683-1-git-send-email-uboot@andestech.com
State Superseded
Delegated to: Andes
Headers show
Series [U-Boot,v2,1/3] ae3xx: timer: Rename AE3XX to ATCPIT100 | expand

Commit Message

Andes Nov. 27, 2017, 2:33 a.m. UTC
From: Rick Chen <rick@andestech.com>

ATCPIT100 is Andestech timer IP which is embeded
in AE3XX and AE250 boards. So rename AE3XX to
ATCPIT100 will be more make sence.

Signed-off-by: Rick Chen <rick@andestech.com>
---
Changelog v2
 - Patch 1/3: Changed.
 - Patch 2/3: Changed.
 - Patch 3/3: No change.

Patch 1/3
 1. Only rename ae3xx as atcpit100.
 2. Squashed Kconfig rename ae3xx into this patch
    to keep things in a consistent state.

Patch 2/3
 1. Modify function name from ae3xx to atcpit100.
---
 configs/adp-ae3xx_defconfig                        | 2 +-
 drivers/timer/Kconfig                              | 7 ++++---
 drivers/timer/Makefile                             | 2 +-
 drivers/timer/{ae3xx_timer.c => atcpit100_timer.c} | 0
 4 files changed, 6 insertions(+), 5 deletions(-)
 rename drivers/timer/{ae3xx_timer.c => atcpit100_timer.c} (100%)

Comments

Simon Glass Nov. 27, 2017, 5:10 p.m. UTC | #1
On 26 November 2017 at 19:33, Andes <uboot@andestech.com> wrote:
> From: Rick Chen <rick@andestech.com>
>
> ATCPIT100 is Andestech timer IP which is embeded
> in AE3XX and AE250 boards. So rename AE3XX to
> ATCPIT100 will be more make sence.
>
> Signed-off-by: Rick Chen <rick@andestech.com>
> ---
> Changelog v2
>  - Patch 1/3: Changed.
>  - Patch 2/3: Changed.
>  - Patch 3/3: No change.
>
> Patch 1/3
>  1. Only rename ae3xx as atcpit100.
>  2. Squashed Kconfig rename ae3xx into this patch
>     to keep things in a consistent state.
>
> Patch 2/3
>  1. Modify function name from ae3xx to atcpit100.
> ---
>  configs/adp-ae3xx_defconfig                        | 2 +-
>  drivers/timer/Kconfig                              | 7 ++++---
>  drivers/timer/Makefile                             | 2 +-
>  drivers/timer/{ae3xx_timer.c => atcpit100_timer.c} | 0
>  4 files changed, 6 insertions(+), 5 deletions(-)
>  rename drivers/timer/{ae3xx_timer.c => atcpit100_timer.c} (100%)
>

Reviewed-by: Simon Glass <sjg@chromium.org>
diff mbox series

Patch

diff --git a/configs/adp-ae3xx_defconfig b/configs/adp-ae3xx_defconfig
index a3a40bf..337cee1 100644
--- a/configs/adp-ae3xx_defconfig
+++ b/configs/adp-ae3xx_defconfig
@@ -35,4 +35,4 @@  CONFIG_SYS_NS16550=y
 CONFIG_DM_SPI=y
 CONFIG_NDS_AE3XX_SPI=y
 CONFIG_TIMER=y
-CONFIG_AE3XX_TIMER=y
+CONFIG_ATCPIT100_TIMER=y
diff --git a/drivers/timer/Kconfig b/drivers/timer/Kconfig
index 6305bbf..fcfdf4e 100644
--- a/drivers/timer/Kconfig
+++ b/drivers/timer/Kconfig
@@ -105,11 +105,12 @@  config AG101P_TIMER
 	help
 	  Select this to enable a timer for AG01P devices.
 
-config AE3XX_TIMER
-	bool "AE3XX timer support"
+config ATCPIT100_TIMER
+	bool "ATCPIT100 timer support"
 	depends on TIMER && NDS32
 	help
-	  Select this to enable a timer for AE3XX devices.
+	  Select this to enable a ATCPIT100 timer which will be embeded
+		in AE3XX, AE250 boards.
 
 config ROCKCHIP_TIMER
         bool "Rockchip timer support"
diff --git a/drivers/timer/Makefile b/drivers/timer/Makefile
index 69e8961..15e5154 100644
--- a/drivers/timer/Makefile
+++ b/drivers/timer/Makefile
@@ -13,6 +13,6 @@  obj-$(CONFIG_AST_TIMER)	+= ast_timer.o
 obj-$(CONFIG_STI_TIMER)		+= sti-timer.o
 obj-$(CONFIG_ARC_TIMER)	+= arc_timer.o
 obj-$(CONFIG_AG101P_TIMER) += ag101p_timer.o
-obj-$(CONFIG_AE3XX_TIMER) += ae3xx_timer.o
+obj-$(CONFIG_ATCPIT100_TIMER) += atcpit100_timer.o
 obj-$(CONFIG_ROCKCHIP_TIMER) += rockchip_timer.o
 obj-$(CONFIG_ATMEL_PIT_TIMER) += atmel_pit_timer.o
diff --git a/drivers/timer/ae3xx_timer.c b/drivers/timer/atcpit100_timer.c
similarity index 100%
rename from drivers/timer/ae3xx_timer.c
rename to drivers/timer/atcpit100_timer.c