diff mbox series

Rename existing insn_cost to insn_sched_cost

Message ID 01cd3b1eb6c8f0ef336ce2850dcd2edf52b11684.1506003847.git.segher@kernel.crashing.org
State New
Headers show
Series Rename existing insn_cost to insn_sched_cost | expand

Commit Message

Segher Boessenkool Sept. 21, 2017, 2:28 p.m. UTC
haifa-sched exports an insn_cost function, but it is only used in a
few places and specialised to scheduling.  This patch renames it to
insn_sched_cost.

Okayed by Jeff at https://gcc.gnu.org/ml/gcc-patches/2017-08/msg00202.html,
committing it now.


Segher


2017-09-21  Segher Boessenkool  <segher@kernel.crashing.org>

	* haifa-sched.c: Rename insn_cost to insn_sched_cost.
	* sched-rgn.c: Ditto.
	* sel-sched-ir.c: Ditto.

---
 gcc/haifa-sched.c  | 14 +++++++-------
 gcc/sched-int.h    |  2 +-
 gcc/sched-rgn.c    |  4 ++--
 gcc/sel-sched-ir.c |  2 +-
 4 files changed, 11 insertions(+), 11 deletions(-)

Comments

Richard Sandiford Sept. 21, 2017, 9:36 p.m. UTC | #1
Segher Boessenkool <segher@kernel.crashing.org> writes:
> haifa-sched exports an insn_cost function, but it is only used in a
> few places and specialised to scheduling.  This patch renames it to
> insn_sched_cost.
>
> Okayed by Jeff at https://gcc.gnu.org/ml/gcc-patches/2017-08/msg00202.html,
> committing it now.

I committed this follow-up as obvious.  No other ports seem to be affected.

Thanks,
Richard


2017-09-21  Richard Sandiford  <richard.sandiford@linaro.org>

gcc/
	* config/spu/spu.c (spu_sched_adjust_cost): Update after renaming
	of insn_cost.

Index: gcc/config/spu/spu.c
===================================================================
--- gcc/config/spu/spu.c	2017-09-21 11:53:16.516954001 +0100
+++ gcc/config/spu/spu.c	2017-09-21 22:35:03.426465252 +0100
@@ -3055,7 +3055,7 @@ spu_sched_adjust_cost (rtx_insn *insn, i
      jump_insn.  We adjust here so higher cost insns will get scheduled
      earlier. */
   if (JUMP_P (insn) && dep_type == REG_DEP_ANTI)
-    return insn_cost (dep_insn) - 3;
+    return insn_sched_cost (dep_insn) - 3;
 
   return cost;
 }
Segher Boessenkool Sept. 21, 2017, 10:32 p.m. UTC | #2
On Thu, Sep 21, 2017 at 10:36:48PM +0100, Richard Sandiford wrote:
> Segher Boessenkool <segher@kernel.crashing.org> writes:
> > haifa-sched exports an insn_cost function, but it is only used in a
> > few places and specialised to scheduling.  This patch renames it to
> > insn_sched_cost.
> >
> > Okayed by Jeff at https://gcc.gnu.org/ml/gcc-patches/2017-08/msg00202.html,
> > committing it now.
> 
> I committed this follow-up as obvious.  No other ports seem to be affected.

Oh sorry, I somehow missed this.  Thanks for the fix!


Segher
diff mbox series

Patch

diff --git a/gcc/haifa-sched.c b/gcc/haifa-sched.c
index af0ed27..d1378d0 100644
--- a/gcc/haifa-sched.c
+++ b/gcc/haifa-sched.c
@@ -225,7 +225,7 @@  struct common_sched_info_def *common_sched_info;
 #define FEEDS_BACKTRACK_INSN(INSN) (HID (INSN)->feeds_backtrack_insn)
 #define SHADOW_P(INSN) (HID (INSN)->shadow_p)
 #define MUST_RECOMPUTE_SPEC_P(INSN) (HID (INSN)->must_recompute_spec)
-/* Cached cost of the instruction.  Use insn_cost to get cost of the
+/* Cached cost of the instruction.  Use insn_sched_cost to get cost of the
    insn.  -1 here means that the field is not initialized.  */
 #define INSN_COST(INSN)	(HID (INSN)->cost)
 
@@ -1383,7 +1383,7 @@  static rtx_insn *nonscheduled_insns_begin;
    This is the number of cycles between instruction issue and
    instruction results.  */
 int
-insn_cost (rtx_insn *insn)
+insn_sched_cost (rtx_insn *insn)
 {
   int cost;
 
@@ -1470,7 +1470,7 @@  dep_cost_1 (dep_t link, dw_t dw)
     {
       enum reg_note dep_type = DEP_TYPE (link);
 
-      cost = insn_cost (insn);
+      cost = insn_sched_cost (insn);
 
       if (INSN_CODE (insn) >= 0)
 	{
@@ -1608,11 +1608,11 @@  priority (rtx_insn *insn)
 	  INSN_FUSION_PRIORITY (insn) = this_fusion_priority;
 	}
       else if (dep_list_size (insn, SD_LIST_FORW) == 0)
-	/* ??? We should set INSN_PRIORITY to insn_cost when and insn has
-	   some forward deps but all of them are ignored by
+	/* ??? We should set INSN_PRIORITY to insn_sched_cost when and insn
+	   has some forward deps but all of them are ignored by
 	   contributes_to_priority hook.  At the moment we set priority of
 	   such insn to 0.  */
-	this_priority = insn_cost (insn);
+	this_priority = insn_sched_cost (insn);
       else
 	{
 	  rtx_insn *prev_first, *twin;
@@ -1683,7 +1683,7 @@  priority (rtx_insn *insn)
 	{
 	  gcc_assert (this_priority == -1);
 
-	  this_priority = insn_cost (insn);
+	  this_priority = insn_sched_cost (insn);
 	}
 
       INSN_PRIORITY (insn) = this_priority;
diff --git a/gcc/sched-int.h b/gcc/sched-int.h
index 624d892..2af8f9f 100644
--- a/gcc/sched-int.h
+++ b/gcc/sched-int.h
@@ -1403,7 +1403,7 @@  extern void get_ebb_head_tail (basic_block, basic_block,
 			       rtx_insn **, rtx_insn **);
 extern int no_real_insns_p (const rtx_insn *, const rtx_insn *);
 
-extern int insn_cost (rtx_insn *);
+extern int insn_sched_cost (rtx_insn *);
 extern int dep_cost_1 (dep_t, dw_t);
 extern int dep_cost (dep_t);
 extern int set_priorities (rtx_insn *, rtx_insn *);
diff --git a/gcc/sched-rgn.c b/gcc/sched-rgn.c
index 492094e..ba5b47c 100644
--- a/gcc/sched-rgn.c
+++ b/gcc/sched-rgn.c
@@ -2837,8 +2837,8 @@  void debug_dependencies (rtx_insn *head, rtx_insn *tail)
 			       : INSN_PRIORITY (insn))
 		: INSN_PRIORITY (insn)),
 	       (sel_sched_p () ? (sched_emulate_haifa_p ? -1
-			       : insn_cost (insn))
-		: insn_cost (insn)));
+			       : insn_sched_cost (insn))
+		: insn_sched_cost (insn)));
 
       if (recog_memoized (insn) < 0)
 	fprintf (sched_dump, "nothing");
diff --git a/gcc/sel-sched-ir.c b/gcc/sel-sched-ir.c
index fa88259..c0e835f 100644
--- a/gcc/sel-sched-ir.c
+++ b/gcc/sel-sched-ir.c
@@ -1324,7 +1324,7 @@  sel_insn_rtx_cost (rtx_insn *insn)
 }
 
 /* Return the cost of the VI.
-   !!! FIXME: Unify with haifa-sched.c: insn_cost ().  */
+   !!! FIXME: Unify with haifa-sched.c: insn_sched_cost ().  */
 int
 sel_vinsn_cost (vinsn_t vi)
 {