[ovs-dev,branch-2.8] docs: Use DPDK 17.05.2 release.

Message ID 1505311069-11438-1-git-send-email-ian.stokes@intel.com
State Not Applicable
Delegated to: Darrell Ball
Headers show
Series
  • [ovs-dev,branch-2.8] docs: Use DPDK 17.05.2 release.
Related show

Commit Message

Stokes, Ian Sept. 13, 2017, 1:57 p.m.
Modify docs and travis linux build script to use the DPDK 17.05.2
release branch to benefit from most recent bug fixes.

There are no new features introduced in the DPDK release, only back
ported bug fixes. For completeness these bug fixes have been
documented under the 17.05.2 section in the link below.

http://dpdk.org/doc/guides-17.05/rel_notes/release_17_05.html

Signed-off-by: Ian Stokes <ian.stokes@intel.com>
---
 .travis/linux-build.sh                   |    2 +-
 Documentation/faq/releases.rst           |    4 ++--
 Documentation/intro/install/dpdk.rst     |    8 ++++----
 Documentation/topics/dpdk/vhost-user.rst |    8 ++++----
 4 files changed, 11 insertions(+), 11 deletions(-)

Patch

diff --git a/.travis/linux-build.sh b/.travis/linux-build.sh
index bc7c708..4d6459f 100755
--- a/.travis/linux-build.sh
+++ b/.travis/linux-build.sh
@@ -81,7 +81,7 @@  fi
 
 if [ "$DPDK" ]; then
     if [ -z "$DPDK_VER" ]; then
-        DPDK_VER="17.05.1"
+        DPDK_VER="17.05.2"
     fi
     install_dpdk $DPDK_VER
     if [ "$CC" = "clang" ]; then
diff --git a/Documentation/faq/releases.rst b/Documentation/faq/releases.rst
index c785529..247e892 100644
--- a/Documentation/faq/releases.rst
+++ b/Documentation/faq/releases.rst
@@ -161,8 +161,8 @@  Q: What DPDK version does each Open vSwitch release work with?
     2.4.x        2.0
     2.5.x        2.2
     2.6.x        16.07.2
-    2.7.x        16.11.2
-    2.8.x        17.05.1
+    2.7.x        16.11.3
+    2.8.x        17.05.2
     ============ =======
 
 Q: I get an error like this when I configure Open vSwitch:
diff --git a/Documentation/intro/install/dpdk.rst b/Documentation/intro/install/dpdk.rst
index 26fe0fe..c678789 100644
--- a/Documentation/intro/install/dpdk.rst
+++ b/Documentation/intro/install/dpdk.rst
@@ -40,7 +40,7 @@  Build requirements
 In addition to the requirements described in :doc:`general`, building Open
 vSwitch with DPDK will require the following:
 
-- DPDK 17.05.1
+- DPDK 17.05.2
 
 - A `DPDK supported NIC`_
 
@@ -69,9 +69,9 @@  Install DPDK
 #. Download the `DPDK sources`_, extract the file and set ``DPDK_DIR``::
 
        $ cd /usr/src/
-       $ wget http://fast.dpdk.org/rel/dpdk-17.05.1.tar.xz
-       $ tar xf dpdk-17.05.1.tar.xz
-       $ export DPDK_DIR=/usr/src/dpdk-stable-17.05.1
+       $ wget http://fast.dpdk.org/rel/dpdk-17.05.2.tar.xz
+       $ tar xf dpdk-17.05.2.tar.xz
+       $ export DPDK_DIR=/usr/src/dpdk-stable-17.05.2
        $ cd $DPDK_DIR
 
 #. (Optional) Configure DPDK as a shared library
diff --git a/Documentation/topics/dpdk/vhost-user.rst b/Documentation/topics/dpdk/vhost-user.rst
index a3d5de3..d383a16 100644
--- a/Documentation/topics/dpdk/vhost-user.rst
+++ b/Documentation/topics/dpdk/vhost-user.rst
@@ -292,9 +292,9 @@  To begin, instantiate a guest as described in :ref:`dpdk-vhost-user` or
 DPDK sources to VM and build DPDK::
 
     $ cd /root/dpdk/
-    $ wget http://fast.dpdk.org/rel/dpdk-17.05.1.tar.xz
-    $ tar xf dpdk-17.05.1.tar.xz
-    $ export DPDK_DIR=/root/dpdk/dpdk-stable-17.05.1
+    $ wget http://fast.dpdk.org/rel/dpdk-17.05.2.tar.xz
+    $ tar xf dpdk-17.05.2.tar.xz
+    $ export DPDK_DIR=/root/dpdk/dpdk-stable-17.05.2
     $ export DPDK_TARGET=x86_64-native-linuxapp-gcc
     $ export DPDK_BUILD=$DPDK_DIR/$DPDK_TARGET
     $ cd $DPDK_DIR
@@ -378,7 +378,7 @@  Sample XML
         </disk>
         <disk type='dir' device='disk'>
           <driver name='qemu' type='fat'/>
-          <source dir='/usr/src/dpdk-stable-17.05.1'/>
+          <source dir='/usr/src/dpdk-stable-17.05.2'/>
           <target dev='vdb' bus='virtio'/>
           <readonly/>
         </disk>