[2/5] package/ngircd: add optional dependency to openssl

Message ID 20170913122958.11805-2-bernd.kuhls@t-online.de
State New
Headers show
Series
  • [1/5] package/ngircd: bump version to 24
Related show

Commit Message

Bernd Kuhls Sept. 13, 2017, 12:29 p.m.
Signed-off-by: Bernd Kuhls <bernd.kuhls@t-online.de>
---
 package/ngircd/ngircd.mk | 7 +++++++
 1 file changed, 7 insertions(+)

Patch

diff --git a/package/ngircd/ngircd.mk b/package/ngircd/ngircd.mk
index 5f03b66001..2ab9187c8e 100644
--- a/package/ngircd/ngircd.mk
+++ b/package/ngircd/ngircd.mk
@@ -11,4 +11,11 @@  NGIRCD_DEPENDENCIES = zlib
 NGIRCD_LICENSE = GPL-2.0+
 NGIRCD_LICENSE_FILES = COPYING
 
+ifeq ($(BR2_PACKAGE_OPENSSL),y)
+NGIRCD_CONF_OPTS += --with-openssl=$(STAGING_DIR)/usr
+NGIRCD_DEPENDENCIES += openssl
+else
+NGIRCD_CONF_OPTS += --without-openssl
+endif
+
 $(eval $(autotools-package))