[3/5] package/ngircd: add optional support for gnutls

Message ID 20170913122958.11805-3-bernd.kuhls@t-online.de
State Accepted
Headers show
Series
  • [1/5] package/ngircd: bump version to 24
Related show

Commit Message

Bernd Kuhls Sept. 13, 2017, 12:29 p.m.
openssl and gnutls can not be enabled at the same time:
https://github.com/ngircd/ngircd/blob/master/configure.ng#L449

Signed-off-by: Bernd Kuhls <bernd.kuhls@t-online.de>
---
 package/ngircd/ngircd.mk | 6 ++++++
 1 file changed, 6 insertions(+)

Patch

diff --git a/package/ngircd/ngircd.mk b/package/ngircd/ngircd.mk
index 2ab9187c8e..06318a9df3 100644
--- a/package/ngircd/ngircd.mk
+++ b/package/ngircd/ngircd.mk
@@ -16,6 +16,12 @@  NGIRCD_CONF_OPTS += --with-openssl=$(STAGING_DIR)/usr
 NGIRCD_DEPENDENCIES += openssl
 else
 NGIRCD_CONF_OPTS += --without-openssl
+ifeq ($(BR2_PACKAGE_GNUTLS),y)
+NGIRCD_CONF_OPTS += --with-gnutls=$(STAGING_DIR)/usr
+NGIRCD_DEPENDENCIES += gnutls
+else
+NGIRCD_CONF_OPTS += --without-gnutls
+endif
 endif
 
 $(eval $(autotools-package))