[ovs-dev,V2,14/16] acinclude: Add support for Linux 4.13

Message ID 1505164269-9455-14-git-send-email-gvrose8192@gmail.com
State Accepted
Headers show
Series
  • [ovs-dev,V2,01/16] acinclude: Check for SKB_GSO_UDP
Related show

Commit Message

Gregory Rose Sept. 11, 2017, 9:11 p.m.
Add configuration support for the just released 4.13 Linux kernel.

Signed-off-by: Greg Rose <gvrose8192@gmail.com>
---
 acinclude.m4 | 4 ++--
 1 file changed, 2 insertions(+), 2 deletions(-)

Patch

diff --git a/acinclude.m4 b/acinclude.m4
index 46efa69..cb5f3ae 100644
--- a/acinclude.m4
+++ b/acinclude.m4
@@ -143,10 +143,10 @@  AC_DEFUN([OVS_CHECK_LINUX], [
     AC_MSG_RESULT([$kversion])
 
     if test "$version" -ge 4; then
-       if test "$version" = 4 && test "$patchlevel" -le 12; then
+       if test "$version" = 4 && test "$patchlevel" -le 13; then
           : # Linux 4.x
        else
-          AC_ERROR([Linux kernel in $KBUILD is version $kversion, but version newer than 4.11.x is not supported (please refer to the FAQ for advice)])
+          AC_ERROR([Linux kernel in $KBUILD is version $kversion, but version newer than 4.13.x is not supported (please refer to the FAQ for advice)])
        fi
     elif test "$version" = 3 && test "$patchlevel" -ge 10; then
        : # Linux 3.x