libgo patch committed: Use -std=gnu99 for mksysinfo

Submitted by Ian Taylor on Jan. 28, 2011, 11:54 p.m.

Details

Message ID mcrvd18shwt.fsf@google.com
State New
Headers show

Commit Message

Ian Taylor Jan. 28, 2011, 11:54 p.m.
On Solaris mksysinfo.sh needs to use -std=gnu99, and that should, I
hope, do no harm on other platforms.  This libgo patch changes it.
Bootstrapped and ran Go testsuite on x86_64-unknown-linux-gnu.
Committed to mainline.

Ian

Patch hide | download patch | download mbox

diff -r 7c5eab536ceb libgo/mksysinfo.sh
--- a/libgo/mksysinfo.sh	Fri Jan 28 15:31:17 2011 -0800
+++ b/libgo/mksysinfo.sh	Fri Jan 28 15:48:56 2011 -0800
@@ -64,7 +64,7 @@ 
 #include <unistd.h>
 EOF
 
-${CC} -fdump-go-spec=gen-sysinfo.go -S -o sysinfo.s sysinfo.c
+${CC} -fdump-go-spec=gen-sysinfo.go -std=gnu99 -S -o sysinfo.s sysinfo.c
 
 echo 'package syscall' > ${OUT}