[azure,v2,07/19] UBUNTU: [Config] azure: X86_AMD_PLATFORM_DEVICE=n

Message ID 1504211770-14121-8-git-send-email-marcelo.cerri@canonical.com
State New
Headers show
Series
  • linux-azure: remove unused bits
Related show

Commit Message

Marcelo Henrique Cerri Aug. 31, 2017, 8:35 p.m.
BugLink: http://bugs.launchpad.net/bugs/1710261

Signed-off-by: Marcelo Henrique Cerri <marcelo.cerri@canonical.com>
---
 debian.azure/config/config.common.ubuntu | 16 ++--------------
 1 file changed, 2 insertions(+), 14 deletions(-)

Patch

diff --git a/debian.azure/config/config.common.ubuntu b/debian.azure/config/config.common.ubuntu
index 9c8fae28bbac..054cb8fbac71 100644
--- a/debian.azure/config/config.common.ubuntu
+++ b/debian.azure/config/config.common.ubuntu
@@ -935,7 +935,6 @@  CONFIG_DEBUG_KERNEL=y
 # CONFIG_DEBUG_PAGE_REF is not set
 # CONFIG_DEBUG_PERF_USE_VMALLOC is not set
 # CONFIG_DEBUG_PER_CPU_MAPS is not set
-# CONFIG_DEBUG_PINCTRL is not set
 # CONFIG_DEBUG_PI_LIST is not set
 # CONFIG_DEBUG_RODATA_TEST is not set
 # CONFIG_DEBUG_RT_MUTEXES is not set
@@ -1422,7 +1421,6 @@  CONFIG_GENERIC_NET_UTILS=y
 CONFIG_GENERIC_PCI_IOMAP=y
 CONFIG_GENERIC_PENDING_IRQ=y
 CONFIG_GENERIC_PHY=y
-CONFIG_GENERIC_PINCONF=y
 CONFIG_GENERIC_SMP_IDLE_THREAD=y
 CONFIG_GENERIC_STRNCPY_FROM_USER=y
 CONFIG_GENERIC_STRNLEN_USER=y
@@ -1757,7 +1755,6 @@  CONFIG_I2C_MUX=m
 # CONFIG_I2C_MUX_MLXCPLD is not set
 # CONFIG_I2C_MUX_PCA9541 is not set
 # CONFIG_I2C_MUX_PCA954x is not set
-# CONFIG_I2C_MUX_PINCTRL is not set
 # CONFIG_I2C_MUX_REG is not set
 CONFIG_I2C_NFORCE2=m
 CONFIG_I2C_NFORCE2_S4985=m
@@ -3306,15 +3303,6 @@  CONFIG_PHYS_ADDR_T_64BIT=y
 # CONFIG_PHY_PXA_28NM_HSIC is not set
 # CONFIG_PHY_PXA_28NM_USB2 is not set
 CONFIG_PID_NS=y
-CONFIG_PINCONF=y
-CONFIG_PINCTRL=y
-# CONFIG_PINCTRL_AMD is not set
-CONFIG_PINCTRL_BAYTRAIL=y
-# CONFIG_PINCTRL_BROXTON is not set
-CONFIG_PINCTRL_CHERRYVIEW=n
-# CONFIG_PINCTRL_GEMINILAKE is not set
-# CONFIG_PINCTRL_SUNRISEPOINT is not set
-CONFIG_PINMUX=y
 CONFIG_PKCS7_MESSAGE_PARSER=y
 CONFIG_PKCS7_TEST_KEY=m
 # CONFIG_PLIP is not set
@@ -4439,7 +4427,7 @@  CONFIG_X86_64_SMP=y
 CONFIG_X86_ACPI_CPUFREQ=y
 CONFIG_X86_ACPI_CPUFREQ_CPB=y
 # CONFIG_X86_AMD_FREQ_SENSITIVITY is not set
-CONFIG_X86_AMD_PLATFORM_DEVICE=y
+# CONFIG_X86_AMD_PLATFORM_DEVICE is not set
 CONFIG_X86_BOOTPARAM_MEMORY_CORRUPTION_CHECK=y
 CONFIG_X86_CHECK_BIOS_CORRUPTION=y
 CONFIG_X86_CMOV=y
@@ -4455,7 +4443,7 @@  CONFIG_X86_EXTENDED_PLATFORM=y
 CONFIG_X86_FAST_FEATURE_TESTS=y
 CONFIG_X86_FEATURE_NAMES=y
 # CONFIG_X86_GOLDFISH is not set
-CONFIG_X86_INTEL_LPSS=n
+# CONFIG_X86_INTEL_LPSS is not set
 CONFIG_X86_INTEL_MEMORY_PROTECTION_KEYS=y
 # CONFIG_X86_INTEL_MID is not set
 CONFIG_X86_INTEL_MPX=y