[6/6] package/linphone: fix URL of Debian patches

Message ID 20170829191005.19697-6-bernd.kuhls@t-online.de
State New
Headers show
Series
  • [1/6] package/dialog: fix upstream source URL
Related show

Commit Message

Bernd Kuhls Aug. 29, 2017, 7:10 p.m.
Signed-off-by: Bernd Kuhls <bernd.kuhls@t-online.de>
---
 package/linphone/linphone.mk | 8 ++++----
 1 file changed, 4 insertions(+), 4 deletions(-)

Comments

Thomas Petazzoni Aug. 29, 2017, 7:52 p.m. | #1
Hello,

On Tue, 29 Aug 2017 21:10:05 +0200, Bernd Kuhls wrote:

> -	https://sources.debian.net/data/main/l/linphone/3.6.1-2.5/debian/patches/libav9.patch \
> -	https://sources.debian.net/data/main/l/linphone/3.6.1-2.5/debian/patches/libav10.patch \
> -	https://sources.debian.net/data/main/l/linphone/3.6.1-2.5/debian/patches/libav11.patch \
> -	https://sources.debian.net/data/main/l/linphone/3.6.1-2.5/debian/patches/ffmpeg_2.9.patch
> +	https://sources.debian.net/data/main/l/linphone/3.6.1-3/debian/patches/libav9.patch \
> +	https://sources.debian.net/data/main/l/linphone/3.6.1-3/debian/patches/libav10.patch \
> +	https://sources.debian.net/data/main/l/linphone/3.6.1-3/debian/patches/libav11.patch \
> +	https://sources.debian.net/data/main/l/linphone/3.6.1-3/debian/patches/ffmpeg_2.9.patch

We will have to constantly update those, because sources.debian.net
doesn't keep all versions of a package, only the most recent ones.

Can we use
http://snapshot.debian.org/archive/debian/20161118T211932Z/pool/main/l/linphone/linphone_3.6.1-3.debian.tar.xz
instead ? This URL is guaranteed to not change.

Thanks,

Thomas

Patch

diff --git a/package/linphone/linphone.mk b/package/linphone/linphone.mk
index fb5e18db6..12b0f10a6 100644
--- a/package/linphone/linphone.mk
+++ b/package/linphone/linphone.mk
@@ -16,10 +16,10 @@  LINPHONE_DEPENDENCIES = host-pkgconf libeXosip2 speex
 LINPHONE_LICENSE = GPL-2.0+
 LINPHONE_LICENSE_FILES = COPYING
 LINPHONE_PATCH = \
-	https://sources.debian.net/data/main/l/linphone/3.6.1-2.5/debian/patches/libav9.patch \
-	https://sources.debian.net/data/main/l/linphone/3.6.1-2.5/debian/patches/libav10.patch \
-	https://sources.debian.net/data/main/l/linphone/3.6.1-2.5/debian/patches/libav11.patch \
-	https://sources.debian.net/data/main/l/linphone/3.6.1-2.5/debian/patches/ffmpeg_2.9.patch
+	https://sources.debian.net/data/main/l/linphone/3.6.1-3/debian/patches/libav9.patch \
+	https://sources.debian.net/data/main/l/linphone/3.6.1-3/debian/patches/libav10.patch \
+	https://sources.debian.net/data/main/l/linphone/3.6.1-3/debian/patches/libav11.patch \
+	https://sources.debian.net/data/main/l/linphone/3.6.1-3/debian/patches/ffmpeg_2.9.patch
 
 ifeq ($(BR2_arc),y)
 # toolchain __arc__ define conflicts with libosip2 source