diff mbox

[v2,BUGFIX] gpio: reject invalid gpio before getting gpio_desc

Message ID 150146625669.11567.9576692487524672090.stgit@devbox
State New
Headers show

Commit Message

Masami Hiramatsu (Google) July 31, 2017, 1:57 a.m. UTC
Check user-given gpio number and reject it before
calling gpio_to_desc() because gpio_to_desc() is
for kernel driver and it expects given gpio number
is valid (means 0 to 511).
If given number is invalid, gpio_to_desc() calls
WARN() and dump registers and stack for debug.
This means user can easily kick WARN() just by
writing invalid gpio number (e.g. 512) to
/sys/class/gpio/export.

Fixes: 0e9a5edf5d01 ("gpio: fix deferred probe detection for legacy API")
Signed-off-by: Masami Hiramatsu <mhiramat@kernel.org>
---
  Changes in v2:
   - Add gpio_to_valid_desc() according to Andy's comment (Thanks!).
   - Fix patch description.
---
 drivers/gpio/gpiolib-sysfs.c |   12 ++++++++++--
 1 file changed, 10 insertions(+), 2 deletions(-)


--
To unsubscribe from this list: send the line "unsubscribe linux-gpio" in
the body of a message to majordomo@vger.kernel.org
More majordomo info at  http://vger.kernel.org/majordomo-info.html

Comments

Linus Walleij Aug. 1, 2017, 8:09 a.m. UTC | #1
On Mon, Jul 31, 2017 at 3:57 AM, Masami Hiramatsu <mhiramat@kernel.org> wrote:

> Check user-given gpio number and reject it before
> calling gpio_to_desc() because gpio_to_desc() is
> for kernel driver and it expects given gpio number
> is valid (means 0 to 511).
> If given number is invalid, gpio_to_desc() calls
> WARN() and dump registers and stack for debug.
> This means user can easily kick WARN() just by
> writing invalid gpio number (e.g. 512) to
> /sys/class/gpio/export.
>
> Fixes: 0e9a5edf5d01 ("gpio: fix deferred probe detection for legacy API")
> Signed-off-by: Masami Hiramatsu <mhiramat@kernel.org>
> ---
>   Changes in v2:
>    - Add gpio_to_valid_desc() according to Andy's comment (Thanks!).
>    - Fix patch description.

I hate the old sysfs ABI sigh. Thanks for fixing it anyways!

Should this be tagged for stable?

Waiting for Andy's review before applying.

Yours,
Linus Walleij
--
To unsubscribe from this list: send the line "unsubscribe linux-gpio" in
the body of a message to majordomo@vger.kernel.org
More majordomo info at  http://vger.kernel.org/majordomo-info.html
Masami Hiramatsu (Google) Aug. 1, 2017, 8:35 a.m. UTC | #2
On Tue, 1 Aug 2017 10:09:09 +0200
Linus Walleij <linus.walleij@linaro.org> wrote:

> On Mon, Jul 31, 2017 at 3:57 AM, Masami Hiramatsu <mhiramat@kernel.org> wrote:
> 
> > Check user-given gpio number and reject it before
> > calling gpio_to_desc() because gpio_to_desc() is
> > for kernel driver and it expects given gpio number
> > is valid (means 0 to 511).
> > If given number is invalid, gpio_to_desc() calls
> > WARN() and dump registers and stack for debug.
> > This means user can easily kick WARN() just by
> > writing invalid gpio number (e.g. 512) to
> > /sys/class/gpio/export.
> >
> > Fixes: 0e9a5edf5d01 ("gpio: fix deferred probe detection for legacy API")
> > Signed-off-by: Masami Hiramatsu <mhiramat@kernel.org>
> > ---
> >   Changes in v2:
> >    - Add gpio_to_valid_desc() according to Andy's comment (Thanks!).
> >    - Fix patch description.
> 
> I hate the old sysfs ABI sigh. Thanks for fixing it anyways!
> 
> Should this be tagged for stable?

Yes, I think so. Since this has been introduced 3 years ago,
it would be nice to go to older stable trees too.

Thanks,

> 
> Waiting for Andy's review before applying.
> 
> Yours,
> Linus Walleij
Andy Shevchenko Aug. 1, 2017, 11:10 a.m. UTC | #3
On Mon, Jul 31, 2017 at 4:57 AM, Masami Hiramatsu <mhiramat@kernel.org> wrote:
> Check user-given gpio number and reject it before
> calling gpio_to_desc() because gpio_to_desc() is
> for kernel driver and it expects given gpio number
> is valid (means 0 to 511).
> If given number is invalid, gpio_to_desc() calls
> WARN() and dump registers and stack for debug.
> This means user can easily kick WARN() just by
> writing invalid gpio number (e.g. 512) to
> /sys/class/gpio/export.
>

Reviewed-by: Andy Shevchenko <andy.shevchenko@gmail.com>

(2 bikesheds below)

> Fixes: 0e9a5edf5d01 ("gpio: fix deferred probe detection for legacy API")
> Signed-off-by: Masami Hiramatsu <mhiramat@kernel.org>
> ---
>   Changes in v2:
>    - Add gpio_to_valid_desc() according to Andy's comment (Thanks!).
>    - Fix patch description.
> ---
>  drivers/gpio/gpiolib-sysfs.c |   12 ++++++++++--
>  1 file changed, 10 insertions(+), 2 deletions(-)
>
> diff --git a/drivers/gpio/gpiolib-sysfs.c b/drivers/gpio/gpiolib-sysfs.c
> index 4b44dd97c07f..819f36258925 100644
> --- a/drivers/gpio/gpiolib-sysfs.c
> +++ b/drivers/gpio/gpiolib-sysfs.c
> @@ -2,6 +2,7 @@
>  #include <linux/mutex.h>
>  #include <linux/device.h>
>  #include <linux/sysfs.h>
> +#include <linux/gpio.h>
>  #include <linux/gpio/consumer.h>
>  #include <linux/gpio/driver.h>
>  #include <linux/interrupt.h>
> @@ -432,6 +433,11 @@ static struct attribute *gpiochip_attrs[] = {
>  };
>  ATTRIBUTE_GROUPS(gpiochip);
>
> +static struct gpio_desc *gpio_to_valid_desc(int gpio)
> +{
> +       return gpio_is_valid(gpio) ? gpio_to_desc(gpio) : NULL;
> +}
> +
>  /*
>   * /sys/class/gpio/export ... write-only
>   *     integer N ... number of GPIO to export (full access)
> @@ -450,7 +456,8 @@ static ssize_t export_store(struct class *class,
>         if (status < 0)
>                 goto done;
>
> -       desc = gpio_to_desc(gpio);
> +       desc = gpio_to_valid_desc(gpio);

> +

No need, if you wish better to put modified line after comment.

>         /* reject invalid GPIOs */
>         if (!desc) {
>                 pr_warn("%s: invalid GPIO %ld\n", __func__, gpio);
> @@ -492,7 +499,8 @@ static ssize_t unexport_store(struct class *class,
>         if (status < 0)
>                 goto done;
>
> -       desc = gpio_to_desc(gpio);
> +       desc = gpio_to_valid_desc(gpio);

> +


Ditto.

>         /* reject bogus commands (gpio_unexport ignores them) */
>         if (!desc) {
>                 pr_warn("%s: invalid GPIO %ld\n", __func__, gpio);
>
Masami Hiramatsu (Google) Aug. 1, 2017, 12:22 p.m. UTC | #4
On Tue, 1 Aug 2017 14:10:03 +0300
Andy Shevchenko <andy.shevchenko@gmail.com> wrote:

> On Mon, Jul 31, 2017 at 4:57 AM, Masami Hiramatsu <mhiramat@kernel.org> wrote:
> > Check user-given gpio number and reject it before
> > calling gpio_to_desc() because gpio_to_desc() is
> > for kernel driver and it expects given gpio number
> > is valid (means 0 to 511).
> > If given number is invalid, gpio_to_desc() calls
> > WARN() and dump registers and stack for debug.
> > This means user can easily kick WARN() just by
> > writing invalid gpio number (e.g. 512) to
> > /sys/class/gpio/export.
> >
> 
> Reviewed-by: Andy Shevchenko <andy.shevchenko@gmail.com>
> 
> (2 bikesheds below)
> 
> > Fixes: 0e9a5edf5d01 ("gpio: fix deferred probe detection for legacy API")
> > Signed-off-by: Masami Hiramatsu <mhiramat@kernel.org>
> > ---
> >   Changes in v2:
> >    - Add gpio_to_valid_desc() according to Andy's comment (Thanks!).
> >    - Fix patch description.
> > ---
> >  drivers/gpio/gpiolib-sysfs.c |   12 ++++++++++--
> >  1 file changed, 10 insertions(+), 2 deletions(-)
> >
> > diff --git a/drivers/gpio/gpiolib-sysfs.c b/drivers/gpio/gpiolib-sysfs.c
> > index 4b44dd97c07f..819f36258925 100644
> > --- a/drivers/gpio/gpiolib-sysfs.c
> > +++ b/drivers/gpio/gpiolib-sysfs.c
> > @@ -2,6 +2,7 @@
> >  #include <linux/mutex.h>
> >  #include <linux/device.h>
> >  #include <linux/sysfs.h>
> > +#include <linux/gpio.h>
> >  #include <linux/gpio/consumer.h>
> >  #include <linux/gpio/driver.h>
> >  #include <linux/interrupt.h>
> > @@ -432,6 +433,11 @@ static struct attribute *gpiochip_attrs[] = {
> >  };
> >  ATTRIBUTE_GROUPS(gpiochip);
> >
> > +static struct gpio_desc *gpio_to_valid_desc(int gpio)
> > +{
> > +       return gpio_is_valid(gpio) ? gpio_to_desc(gpio) : NULL;
> > +}
> > +
> >  /*
> >   * /sys/class/gpio/export ... write-only
> >   *     integer N ... number of GPIO to export (full access)
> > @@ -450,7 +456,8 @@ static ssize_t export_store(struct class *class,
> >         if (status < 0)
> >                 goto done;
> >
> > -       desc = gpio_to_desc(gpio);
> > +       desc = gpio_to_valid_desc(gpio);
> 
> > +
> 
> No need, if you wish better to put modified line after comment.

OK, should I update the patch and resend?

Thanks,

> 
> >         /* reject invalid GPIOs */
> >         if (!desc) {
> >                 pr_warn("%s: invalid GPIO %ld\n", __func__, gpio);
> > @@ -492,7 +499,8 @@ static ssize_t unexport_store(struct class *class,
> >         if (status < 0)
> >                 goto done;
> >
> > -       desc = gpio_to_desc(gpio);
> > +       desc = gpio_to_valid_desc(gpio);
> 
> > +
> 
> 
> Ditto.
> 
> >         /* reject bogus commands (gpio_unexport ignores them) */
> >         if (!desc) {
> >                 pr_warn("%s: invalid GPIO %ld\n", __func__, gpio);
> >
> 
> 
> 
> -- 
> With Best Regards,
> Andy Shevchenko
diff mbox

Patch

diff --git a/drivers/gpio/gpiolib-sysfs.c b/drivers/gpio/gpiolib-sysfs.c
index 4b44dd97c07f..819f36258925 100644
--- a/drivers/gpio/gpiolib-sysfs.c
+++ b/drivers/gpio/gpiolib-sysfs.c
@@ -2,6 +2,7 @@ 
 #include <linux/mutex.h>
 #include <linux/device.h>
 #include <linux/sysfs.h>
+#include <linux/gpio.h>
 #include <linux/gpio/consumer.h>
 #include <linux/gpio/driver.h>
 #include <linux/interrupt.h>
@@ -432,6 +433,11 @@  static struct attribute *gpiochip_attrs[] = {
 };
 ATTRIBUTE_GROUPS(gpiochip);
 
+static struct gpio_desc *gpio_to_valid_desc(int gpio)
+{
+	return gpio_is_valid(gpio) ? gpio_to_desc(gpio) : NULL;
+}
+
 /*
  * /sys/class/gpio/export ... write-only
  *	integer N ... number of GPIO to export (full access)
@@ -450,7 +456,8 @@  static ssize_t export_store(struct class *class,
 	if (status < 0)
 		goto done;
 
-	desc = gpio_to_desc(gpio);
+	desc = gpio_to_valid_desc(gpio);
+
 	/* reject invalid GPIOs */
 	if (!desc) {
 		pr_warn("%s: invalid GPIO %ld\n", __func__, gpio);
@@ -492,7 +499,8 @@  static ssize_t unexport_store(struct class *class,
 	if (status < 0)
 		goto done;
 
-	desc = gpio_to_desc(gpio);
+	desc = gpio_to_valid_desc(gpio);
+
 	/* reject bogus commands (gpio_unexport ignores them) */
 	if (!desc) {
 		pr_warn("%s: invalid GPIO %ld\n", __func__, gpio);