diff mbox

[V5,1/4] nmi: convert cpu_index to cpu-index

Message ID 4D2AD077.8030204@cn.fujitsu.com
State New
Headers show

Commit Message

Lai Jiangshan Jan. 10, 2011, 9:25 a.m. UTC
"cpu-index" is better name.

Signed-off-by:  Lai Jiangshan <laijs@cn.fujitsu.com>
---
diff mbox

Patch

diff --git a/hmp-commands.hx b/hmp-commands.hx
index df134f8..99b96a8 100644
--- a/hmp-commands.hx
+++ b/hmp-commands.hx
@@ -721,7 +721,7 @@  ETEXI
 #if defined(TARGET_I386)
     {
         .name       = "nmi",
-        .args_type  = "cpu_index:i",
+        .args_type  = "cpu-index:i",
         .params     = "cpu",
         .help       = "inject an NMI on the given CPU",
         .mhandler.cmd = do_inject_nmi,
diff --git a/monitor.c b/monitor.c
index f258000..fd18887 100644
--- a/monitor.c
+++ b/monitor.c
@@ -2520,7 +2520,7 @@  static void do_wav_capture(Monitor *mon, const QDict *qdict)
 static void do_inject_nmi(Monitor *mon, const QDict *qdict)
 {
     CPUState *env;
-    int cpu_index = qdict_get_int(qdict, "cpu_index");
+    int cpu_index = qdict_get_int(qdict, "cpu-index");
 
     for (env = first_cpu; env != NULL; env = env->next_cpu)
         if (env->cpu_index == cpu_index) {