diff mbox

virtio: fix vring_align() on 64-bit win32 platforms

Message ID 20170321223151.12984-1-Andrew.Baumann@microsoft.com
State New
Headers show

Commit Message

Andrew Baumann March 21, 2017, 10:31 p.m. UTC
"long" is 32-bits on win32, but we need to promote it to a 64-bit hwaddr
before negating, or else the top half of the address is truncated

Signed-off-by: Andrew Baumann <Andrew.Baumann@microsoft.com>
---
 include/hw/virtio/virtio.h | 2 +-
 1 file changed, 1 insertion(+), 1 deletion(-)

Comments

Eric Blake March 21, 2017, 10:51 p.m. UTC | #1
On 03/21/2017 05:31 PM, Andrew Baumann wrote:
> "long" is 32-bits on win32, but we need to promote it to a 64-bit hwaddr
> before negating, or else the top half of the address is truncated
> 
> Signed-off-by: Andrew Baumann <Andrew.Baumann@microsoft.com>
> ---
>  include/hw/virtio/virtio.h | 2 +-
>  1 file changed, 1 insertion(+), 1 deletion(-)
> 
> diff --git a/include/hw/virtio/virtio.h b/include/hw/virtio/virtio.h
> index 15efcf2..a0a8543 100644
> --- a/include/hw/virtio/virtio.h
> +++ b/include/hw/virtio/virtio.h
> @@ -34,7 +34,7 @@ struct VirtQueue;
>  static inline hwaddr vring_align(hwaddr addr,
>                                               unsigned long align)
>  {
> -    return (addr + align - 1) & ~(align - 1);
> +    return (addr + align - 1) & ~(hwaddr)(align - 1);

Why not just use the QEMU_ALIGN_DOWN macro, instead of open-coding it?

(Hmm - a good BiteSized task might be to come up with a Coccinelle
script to help replace all open-coded rounding functions with
appropriate macro calls instead)
Andrew Baumann March 21, 2017, 11:06 p.m. UTC | #2
> From: Eric Blake [mailto:eblake@redhat.com]

> Sent: Tuesday, 21 March 2017 15:52

> 

> On 03/21/2017 05:31 PM, Andrew Baumann wrote:

> > "long" is 32-bits on win32, but we need to promote it to a 64-bit hwaddr

> > before negating, or else the top half of the address is truncated

> >

> > Signed-off-by: Andrew Baumann <Andrew.Baumann@microsoft.com>

> > ---

> >  include/hw/virtio/virtio.h | 2 +-

> >  1 file changed, 1 insertion(+), 1 deletion(-)

> >

> > diff --git a/include/hw/virtio/virtio.h b/include/hw/virtio/virtio.h

> > index 15efcf2..a0a8543 100644

> > --- a/include/hw/virtio/virtio.h

> > +++ b/include/hw/virtio/virtio.h

> > @@ -34,7 +34,7 @@ struct VirtQueue;

> >  static inline hwaddr vring_align(hwaddr addr,

> >                                               unsigned long align)

> >  {

> > -    return (addr + align - 1) & ~(align - 1);

> > +    return (addr + align - 1) & ~(hwaddr)(align - 1);

> 

> Why not just use the QEMU_ALIGN_DOWN macro, instead of open-coding it?


Well, this code is aligning up, but yes the ALIGN_UP macro looks like it should also avoid the type promotion problem. This patch is just the minimally-invasive change after discovering the bug.

Let me know if you want me to spin another patch with the macro.

Andrew
Stefan Weil March 22, 2017, 6:11 a.m. UTC | #3
Am 22.03.2017 um 00:06 schrieb Andrew Baumann:
>> From: Eric Blake [mailto:eblake@redhat.com]
>> Sent: Tuesday, 21 March 2017 15:52
>>
>> On 03/21/2017 05:31 PM, Andrew Baumann wrote:
>>> "long" is 32-bits on win32, but we need to promote it to a 64-bit hwaddr
>>> before negating, or else the top half of the address is truncated
>>>
>>> Signed-off-by: Andrew Baumann <Andrew.Baumann@microsoft.com>
>>> ---
>>>  include/hw/virtio/virtio.h | 2 +-
>>>  1 file changed, 1 insertion(+), 1 deletion(-)
>>>
>>> diff --git a/include/hw/virtio/virtio.h b/include/hw/virtio/virtio.h
>>> index 15efcf2..a0a8543 100644
>>> --- a/include/hw/virtio/virtio.h
>>> +++ b/include/hw/virtio/virtio.h
>>> @@ -34,7 +34,7 @@ struct VirtQueue;
>>>  static inline hwaddr vring_align(hwaddr addr,
>>>                                               unsigned long align)
>>>  {
>>> -    return (addr + align - 1) & ~(align - 1);
>>> +    return (addr + align - 1) & ~(hwaddr)(align - 1);
>>
>> Why not just use the QEMU_ALIGN_DOWN macro, instead of open-coding it?
>
> Well, this code is aligning up, but yes the ALIGN_UP macro looks like it should also avoid the type promotion problem. This patch is just the minimally-invasive change after discovering the bug.
>
> Let me know if you want me to spin another patch with the macro.
>
> Andrew

Yes, please use QEMU_ALIGN_UP in an updated patch.
This is a bug fix needed for v2.9.0.

Fixing all other code locations which round up or down
with Coccinelle is a separate task, nothing which is
needed for the next QEMU version.

Thanks,
Stefan
diff mbox

Patch

diff --git a/include/hw/virtio/virtio.h b/include/hw/virtio/virtio.h
index 15efcf2..a0a8543 100644
--- a/include/hw/virtio/virtio.h
+++ b/include/hw/virtio/virtio.h
@@ -34,7 +34,7 @@  struct VirtQueue;
 static inline hwaddr vring_align(hwaddr addr,
                                              unsigned long align)
 {
-    return (addr + align - 1) & ~(align - 1);
+    return (addr + align - 1) & ~(hwaddr)(align - 1);
 }
 
 typedef struct VirtQueue VirtQueue;