install.texi and sparc-*-linux*

Message ID alpine.LNX.2.21.1703182346410.28312@anthias.pfeifer.com
State New
Headers show

Commit Message

Gerald Pfeifer March 19, 2017, 7:40 a.m.
On Sun, 12 Mar 2017, David Miller wrote:
>> Okay to yank it?
> No objections from me.

Thanks.  Here is what I just committed.

Gerald


2017-03-19  Gerald Pfeifer  <gerald@pfeifer.com>

	* doc/install.texi (Specific) <sparc-*-linux*>: No longer refer 
	to age-old versions of binutils and glibc.

Comments

Andreas Schwab March 19, 2017, 8:21 a.m. | #1
On Mär 19 2017, Gerald Pfeifer <gerald@pfeifer.com> wrote:

> Index: doc/install.texi
> ===================================================================
> --- doc/install.texi	(revision 246259)
> +++ doc/install.texi	(working copy)
> @@ -4510,11 +4510,6 @@
>  @anchor{sparc-x-linux}
>  @heading sparc-*-linux*
>  
> -GCC versions 3.0 and higher require binutils 2.11.2 and glibc 2.2.4
> -or newer on this platform.  All earlier binutils and glibc
> -releases mishandled unaligned relocations on @code{sparc-*-*} targets.
> -
> -
>  @html
>  <hr />
>  @end html

The section is now empty.  Should it be removed at all?

Andreas.
Gerald Pfeifer March 20, 2017, 11:16 p.m. | #2
On Sun, 19 Mar 2017, Andreas Schwab wrote:
>>  @anchor{sparc-x-linux}
>>  @heading sparc-*-linux*
> The section is now empty.  Should it be removed at all?

I considered that, but then figured we do want to keep this as
an indicator this is a supported platform (and also placeholder
if/when any new items worth documenting appear).

That said, I don't feel strongly at all and will happily remove
this if that's the preference here.

Gerald
Andreas Schwab March 21, 2017, 6:31 p.m. | #3
On Mär 21 2017, Gerald Pfeifer <gerald@pfeifer.com> wrote:

> On Sun, 19 Mar 2017, Andreas Schwab wrote:
>>>  @anchor{sparc-x-linux}
>>>  @heading sparc-*-linux*
>> The section is now empty.  Should it be removed at all?
>
> I considered that, but then figured we do want to keep this as
> an indicator this is a supported platform (and also placeholder
> if/when any new items worth documenting appear).

There should probably at least be a short description of the target,
like it is present for all other targets without specific instructions.

Andreas.

Patch

Index: doc/install.texi
===================================================================
--- doc/install.texi	(revision 246259)
+++ doc/install.texi	(working copy)
@@ -4510,11 +4510,6 @@ 
 @anchor{sparc-x-linux}
 @heading sparc-*-linux*
 
-GCC versions 3.0 and higher require binutils 2.11.2 and glibc 2.2.4
-or newer on this platform.  All earlier binutils and glibc
-releases mishandled unaligned relocations on @code{sparc-*-*} targets.
-
-
 @html
 <hr />
 @end html