diff mbox

perf: Fix CONFIG_KPROBE_EVENTS and CONFIG_UPROBE_EVENTS typos

Message ID 20170212211449.25976-1-anton@ozlabs.org
State Not Applicable
Delegated to: David Miller
Headers show

Commit Message

Anton Blanchard Feb. 12, 2017, 9:14 p.m. UTC
From: Anton Blanchard <anton@samba.org>

Fix some incorrect Kconfig options, they should be CONFIG_KPROBE_EVENT
and CONFIG_UPROBE_EVENT.

Signed-off-by: Anton Blanchard <anton@samba.org>
---
 arch/sparc/configs/sparc64_defconfig | 2 +-
 tools/perf/util/probe-file.c         | 8 ++++----
 2 files changed, 5 insertions(+), 5 deletions(-)

Comments

David Miller Feb. 13, 2017, 2:49 a.m. UTC | #1
From: Anton Blanchard <anton@ozlabs.org>
Date: Mon, 13 Feb 2017 08:14:49 +1100

> From: Anton Blanchard <anton@samba.org>
> 
> Fix some incorrect Kconfig options, they should be CONFIG_KPROBE_EVENT
> and CONFIG_UPROBE_EVENT.
> 
> Signed-off-by: Anton Blanchard <anton@samba.org>

Acked-by: David S. Miller <davem@davemloft.net>
--
To unsubscribe from this list: send the line "unsubscribe sparclinux" in
the body of a message to majordomo@vger.kernel.org
More majordomo info at  http://vger.kernel.org/majordomo-info.html
Ingo Molnar Feb. 13, 2017, 6:51 a.m. UTC | #2
* Anton Blanchard <anton@ozlabs.org> wrote:

> From: Anton Blanchard <anton@samba.org>
> 
> Fix some incorrect Kconfig options, they should be CONFIG_KPROBE_EVENT
> and CONFIG_UPROBE_EVENT.
> 
> Signed-off-by: Anton Blanchard <anton@samba.org>
> ---
>  arch/sparc/configs/sparc64_defconfig | 2 +-
>  tools/perf/util/probe-file.c         | 8 ++++----
>  2 files changed, 5 insertions(+), 5 deletions(-)

So the names should be fixed, it should be CONFIG_UPROBE_EVENTS and 
CONFIG_KPROBE_EVENTS throughout the code. It's CONFIG_PERF_EVENTS and 
CONFIG_PROBE_EVENTS after all and lives in kernel/events/ - all plural.

I didn't notice the misnomer when merging these bits.

Thanks,

	Ingo
--
To unsubscribe from this list: send the line "unsubscribe sparclinux" in
the body of a message to majordomo@vger.kernel.org
More majordomo info at  http://vger.kernel.org/majordomo-info.html
Anton Blanchard Feb. 16, 2017, 5:59 a.m. UTC | #3
Hi Ingo,

> So the names should be fixed, it should be CONFIG_UPROBE_EVENTS and 
> CONFIG_KPROBE_EVENTS throughout the code. It's CONFIG_PERF_EVENTS and 
> CONFIG_PROBE_EVENTS after all and lives in kernel/events/ - all
> plural.
> 
> I didn't notice the misnomer when merging these bits.

Ok, patch to follow.

Anton
--
To unsubscribe from this list: send the line "unsubscribe sparclinux" in
the body of a message to majordomo@vger.kernel.org
More majordomo info at  http://vger.kernel.org/majordomo-info.html
diff mbox

Patch

diff --git a/arch/sparc/configs/sparc64_defconfig b/arch/sparc/configs/sparc64_defconfig
index b2e650d..f912fd1 100644
--- a/arch/sparc/configs/sparc64_defconfig
+++ b/arch/sparc/configs/sparc64_defconfig
@@ -213,7 +213,7 @@  CONFIG_SCHEDSTATS=y
 # CONFIG_RCU_CPU_STALL_DETECTOR is not set
 CONFIG_SYSCTL_SYSCALL_CHECK=y
 CONFIG_BLK_DEV_IO_TRACE=y
-CONFIG_UPROBE_EVENTS=y
+CONFIG_UPROBE_EVENT=y
 CONFIG_KEYS=y
 CONFIG_CRYPTO_NULL=m
 CONFIG_CRYPTO_TEST=m
diff --git a/tools/perf/util/probe-file.c b/tools/perf/util/probe-file.c
index 436b647..6c74391 100644
--- a/tools/perf/util/probe-file.c
+++ b/tools/perf/util/probe-file.c
@@ -38,9 +38,9 @@  static void print_open_warning(int err, bool uprobe)
 		const char *config;
 
 		if (uprobe)
-			config = "CONFIG_UPROBE_EVENTS";
+			config = "CONFIG_UPROBE_EVENT";
 		else
-			config = "CONFIG_KPROBE_EVENTS";
+			config = "CONFIG_KPROBE_EVENT";
 
 		pr_warning("%cprobe_events file does not exist"
 			   " - please rebuild kernel with %s.\n",
@@ -59,8 +59,8 @@  static void print_both_open_warning(int kerr, int uerr)
 	if (kerr == -ENOTSUP && uerr == -ENOTSUP)
 		pr_warning("Tracefs or debugfs is not mounted.\n");
 	else if (kerr == -ENOENT && uerr == -ENOENT)
-		pr_warning("Please rebuild kernel with CONFIG_KPROBE_EVENTS "
-			   "or/and CONFIG_UPROBE_EVENTS.\n");
+		pr_warning("Please rebuild kernel with CONFIG_KPROBE_EVENT "
+			   "or/and CONFIG_UPROBE_EVENT.\n");
 	else {
 		char sbuf[STRERR_BUFSIZE];
 		pr_warning("Failed to open kprobe events: %s.\n",