diff mbox

sbus: char: Move D7S_MINOR to include/linux/miscdevice.h

Message ID 20161215194703.11195-1-clabbe.montjoie@gmail.com
State Not Applicable
Delegated to: David Miller
Headers show

Commit Message

Corentin Labbe Dec. 15, 2016, 7:47 p.m. UTC
This patch move the define for D7S_MINOR to include/linux/miscdevice.h.
It's better that all minor number are in the same place.

Signed-off-by: Corentin Labbe <clabbe.montjoie@gmail.com>
---
 drivers/sbus/char/display7seg.c | 1 -
 include/linux/miscdevice.h      | 1 +
 2 files changed, 1 insertion(+), 1 deletion(-)

Comments

Julian Calaby Dec. 17, 2016, 1:05 a.m. UTC | #1
Hi Corentin,

On Fri, Dec 16, 2016 at 6:47 AM, Corentin Labbe
<clabbe.montjoie@gmail.com> wrote:
> This patch move the define for D7S_MINOR to include/linux/miscdevice.h.
> It's better that all minor number are in the same place.
>
> Signed-off-by: Corentin Labbe <clabbe.montjoie@gmail.com>
> ---
>  drivers/sbus/char/display7seg.c | 1 -
>  include/linux/miscdevice.h      | 1 +
>  2 files changed, 1 insertion(+), 1 deletion(-)
>
> diff --git a/drivers/sbus/char/display7seg.c b/drivers/sbus/char/display7seg.c
> index 33fbe82..48a5df0 100644
> --- a/drivers/sbus/char/display7seg.c
> +++ b/drivers/sbus/char/display7seg.c
> @@ -22,7 +22,6 @@
>
>  #include <asm/display7seg.h>
>
> -#define D7S_MINOR      193
>  #define DRIVER_NAME    "d7s"
>  #define PFX            DRIVER_NAME ": "
>
> diff --git a/include/linux/miscdevice.h b/include/linux/miscdevice.h
> index 5385d95..b1ba37aef 100644
> --- a/include/linux/miscdevice.h
> +++ b/include/linux/miscdevice.h
> @@ -33,6 +33,7 @@
>  #define I2O_MINOR              166
>  #define HWRNG_MINOR            183
>  #define MICROCODE_MINOR                184
> +#define D7S_MINOR              193

I was going to say "why not change the name to something more
descriptive" however they're all very abbreviated, so maybe consider a
second patch series to describe what each of these is for?

>  #define VFIO_MINOR             196
>  #define TUN_MINOR              200
>  #define CUSE_MINOR             203

Thanks,
gregkh@linuxfoundation.org Jan. 10, 2017, 5:37 p.m. UTC | #2
On Thu, Dec 15, 2016 at 08:47:03PM +0100, Corentin Labbe wrote:
> This patch move the define for D7S_MINOR to include/linux/miscdevice.h.
> It's better that all minor number are in the same place.
> 
> Signed-off-by: Corentin Labbe <clabbe.montjoie@gmail.com>
> ---
>  drivers/sbus/char/display7seg.c | 1 -
>  include/linux/miscdevice.h      | 1 +
>  2 files changed, 1 insertion(+), 1 deletion(-)
> 
> diff --git a/drivers/sbus/char/display7seg.c b/drivers/sbus/char/display7seg.c
> index 33fbe82..48a5df0 100644
> --- a/drivers/sbus/char/display7seg.c
> +++ b/drivers/sbus/char/display7seg.c
> @@ -22,7 +22,6 @@
>  
>  #include <asm/display7seg.h>
>  
> -#define D7S_MINOR	193
>  #define DRIVER_NAME	"d7s"
>  #define PFX		DRIVER_NAME ": "
>  
> diff --git a/include/linux/miscdevice.h b/include/linux/miscdevice.h
> index 5385d95..b1ba37aef 100644
> --- a/include/linux/miscdevice.h
> +++ b/include/linux/miscdevice.h
> @@ -33,6 +33,7 @@
>  #define I2O_MINOR		166
>  #define HWRNG_MINOR		183
>  #define MICROCODE_MINOR		184
> +#define D7S_MINOR		193
>  #define VFIO_MINOR		196
>  #define TUN_MINOR		200
>  #define CUSE_MINOR		203
> -- 

Doesn't apply to my tree :(
--
To unsubscribe from this list: send the line "unsubscribe sparclinux" in
the body of a message to majordomo@vger.kernel.org
More majordomo info at  http://vger.kernel.org/majordomo-info.html
diff mbox

Patch

diff --git a/drivers/sbus/char/display7seg.c b/drivers/sbus/char/display7seg.c
index 33fbe82..48a5df0 100644
--- a/drivers/sbus/char/display7seg.c
+++ b/drivers/sbus/char/display7seg.c
@@ -22,7 +22,6 @@ 
 
 #include <asm/display7seg.h>
 
-#define D7S_MINOR	193
 #define DRIVER_NAME	"d7s"
 #define PFX		DRIVER_NAME ": "
 
diff --git a/include/linux/miscdevice.h b/include/linux/miscdevice.h
index 5385d95..b1ba37aef 100644
--- a/include/linux/miscdevice.h
+++ b/include/linux/miscdevice.h
@@ -33,6 +33,7 @@ 
 #define I2O_MINOR		166
 #define HWRNG_MINOR		183
 #define MICROCODE_MINOR		184
+#define D7S_MINOR		193
 #define VFIO_MINOR		196
 #define TUN_MINOR		200
 #define CUSE_MINOR		203