diff mbox

[U-Boot,v6,1/2] common: usb_storage: Make common function for usb_stor_read/usb_stor_write

Message ID 1465974004-25555-2-git-send-email-rajesh.bhagat@nxp.com
State Superseded
Headers show

Commit Message

Rajesh Bhagat June 15, 2016, 7 a.m. UTC
Performs code cleanup by making common function for usb_stor_read/
usb_stor_write. Currently only difference in these fucntions is call
to usb_read_10/usb_write_10 scsi commands.

Signed-off-by: Rajesh Bhagat <rajesh.bhagat@nxp.com>
---
Changes in v6:
 - Removes USB_STOR_OP_TYPE macro and adds __func__ in debug prints
 - Unifies usb_read_10/usb_write_10 functions to usb_read_write_10

Changes in v5:
 - Converts USB_STOR_OPERATION_FUNC macro to a function
 - Corrects the multi line comment accroding to coding style
 - Renames variable to dev to remove code duplication

Changes in v4:
 - Adds code to make common function for read/write

 common/usb_storage.c | 147 +++++++++++++--------------------------------------
 1 file changed, 36 insertions(+), 111 deletions(-)

Comments

Marek Vasut June 15, 2016, 10:03 p.m. UTC | #1
On 06/15/2016 09:00 AM, Rajesh Bhagat wrote:
> Performs code cleanup by making common function for usb_stor_read/
> usb_stor_write. Currently only difference in these fucntions is call
> to usb_read_10/usb_write_10 scsi commands.
> 
> Signed-off-by: Rajesh Bhagat <rajesh.bhagat@nxp.com>
> ---
> Changes in v6:
>  - Removes USB_STOR_OP_TYPE macro and adds __func__ in debug prints
>  - Unifies usb_read_10/usb_write_10 functions to usb_read_write_10
> 
> Changes in v5:
>  - Converts USB_STOR_OPERATION_FUNC macro to a function
>  - Corrects the multi line comment accroding to coding style
>  - Renames variable to dev to remove code duplication
> 
> Changes in v4:
>  - Adds code to make common function for read/write
> 
>  common/usb_storage.c | 147 +++++++++++++--------------------------------------
>  1 file changed, 36 insertions(+), 111 deletions(-)
> 
> diff --git a/common/usb_storage.c b/common/usb_storage.c
> index 7e6e52d..41e5aa3 100644
> --- a/common/usb_storage.c
> +++ b/common/usb_storage.c
> @@ -1046,11 +1046,11 @@ static int usb_read_capacity(ccb *srb, struct us_data *ss)
>  	return -1;
>  }
>  
> -static int usb_read_10(ccb *srb, struct us_data *ss, unsigned long start,
> -		       unsigned short blocks)
> +static int usb_read_write_10(ccb *srb, struct us_data *ss, unsigned long start,
> +		       unsigned short blocks, bool is_write)
>  {
>  	memset(&srb->cmd[0], 0, 12);
> -	srb->cmd[0] = SCSI_READ10;
> +	srb->cmd[0] = is_write ? SCSI_WRITE10 : SCSI_READ10;
>  	srb->cmd[1] = srb->lun << 5;
>  	srb->cmd[2] = ((unsigned char) (start >> 24)) & 0xff;
>  	srb->cmd[3] = ((unsigned char) (start >> 16)) & 0xff;
> @@ -1059,28 +1059,10 @@ static int usb_read_10(ccb *srb, struct us_data *ss, unsigned long start,
>  	srb->cmd[7] = ((unsigned char) (blocks >> 8)) & 0xff;
>  	srb->cmd[8] = (unsigned char) blocks & 0xff;
>  	srb->cmdlen = 12;
> -	debug("read10: start %lx blocks %x\n", start, blocks);
> +	debug("%s: start %lx blocks %x\n", __func__, start, blocks);
>  	return ss->transport(srb, ss);
>  }
>  
> -static int usb_write_10(ccb *srb, struct us_data *ss, unsigned long start,
> -			unsigned short blocks)
> -{
> -	memset(&srb->cmd[0], 0, 12);
> -	srb->cmd[0] = SCSI_WRITE10;
> -	srb->cmd[1] = srb->lun << 5;
> -	srb->cmd[2] = ((unsigned char) (start >> 24)) & 0xff;
> -	srb->cmd[3] = ((unsigned char) (start >> 16)) & 0xff;
> -	srb->cmd[4] = ((unsigned char) (start >> 8)) & 0xff;
> -	srb->cmd[5] = ((unsigned char) (start)) & 0xff;
> -	srb->cmd[7] = ((unsigned char) (blocks >> 8)) & 0xff;
> -	srb->cmd[8] = (unsigned char) blocks & 0xff;
> -	srb->cmdlen = 12;
> -	debug("write10: start %lx blocks %x\n", start, blocks);
> -	return ss->transport(srb, ss);
> -}
> -

This stuff should be in a separate patch, otherwise it's not bisectable.
Looks pretty OK otherwise.

[...]
Rajesh Bhagat June 16, 2016, 4:40 a.m. UTC | #2
> -----Original Message-----
> From: Marek Vasut [mailto:marex@denx.de]
> Sent: Thursday, June 16, 2016 3:33 AM
> To: Rajesh Bhagat <rajesh.bhagat@nxp.com>; u-boot@lists.denx.de
> Cc: sjg@chromium.org; york sun <york.sun@nxp.com>; Sriram Dash
> <sriram.dash@nxp.com>
> Subject: Re: [PATCH v6 1/2] common: usb_storage: Make common function for
> usb_stor_read/usb_stor_write
> 
> On 06/15/2016 09:00 AM, Rajesh Bhagat wrote:
> > Performs code cleanup by making common function for usb_stor_read/
> > usb_stor_write. Currently only difference in these fucntions is call
> > to usb_read_10/usb_write_10 scsi commands.
> >
> > Signed-off-by: Rajesh Bhagat <rajesh.bhagat@nxp.com>
> > ---
> > Changes in v6:
> >  - Removes USB_STOR_OP_TYPE macro and adds __func__ in debug prints
> >  - Unifies usb_read_10/usb_write_10 functions to usb_read_write_10
> >
> > Changes in v5:
> >  - Converts USB_STOR_OPERATION_FUNC macro to a function
> >  - Corrects the multi line comment accroding to coding style
> >  - Renames variable to dev to remove code duplication
> >
> > Changes in v4:
> >  - Adds code to make common function for read/write
> >
> >  common/usb_storage.c | 147
> > +++++++++++++--------------------------------------
> >  1 file changed, 36 insertions(+), 111 deletions(-)
> >
> > diff --git a/common/usb_storage.c b/common/usb_storage.c index
> > 7e6e52d..41e5aa3 100644
> > --- a/common/usb_storage.c
> > +++ b/common/usb_storage.c
> > @@ -1046,11 +1046,11 @@ static int usb_read_capacity(ccb *srb, struct us_data
> *ss)
> >  	return -1;
> >  }
> >
> > -static int usb_read_10(ccb *srb, struct us_data *ss, unsigned long start,
> > -		       unsigned short blocks)
> > +static int usb_read_write_10(ccb *srb, struct us_data *ss, unsigned long start,
> > +		       unsigned short blocks, bool is_write)
> >  {
> >  	memset(&srb->cmd[0], 0, 12);
> > -	srb->cmd[0] = SCSI_READ10;
> > +	srb->cmd[0] = is_write ? SCSI_WRITE10 : SCSI_READ10;
> >  	srb->cmd[1] = srb->lun << 5;
> >  	srb->cmd[2] = ((unsigned char) (start >> 24)) & 0xff;
> >  	srb->cmd[3] = ((unsigned char) (start >> 16)) & 0xff; @@ -1059,28
> > +1059,10 @@ static int usb_read_10(ccb *srb, struct us_data *ss, unsigned long
> start,
> >  	srb->cmd[7] = ((unsigned char) (blocks >> 8)) & 0xff;
> >  	srb->cmd[8] = (unsigned char) blocks & 0xff;
> >  	srb->cmdlen = 12;
> > -	debug("read10: start %lx blocks %x\n", start, blocks);
> > +	debug("%s: start %lx blocks %x\n", __func__, start, blocks);
> >  	return ss->transport(srb, ss);
> >  }
> >
> > -static int usb_write_10(ccb *srb, struct us_data *ss, unsigned long start,
> > -			unsigned short blocks)
> > -{
> > -	memset(&srb->cmd[0], 0, 12);
> > -	srb->cmd[0] = SCSI_WRITE10;
> > -	srb->cmd[1] = srb->lun << 5;
> > -	srb->cmd[2] = ((unsigned char) (start >> 24)) & 0xff;
> > -	srb->cmd[3] = ((unsigned char) (start >> 16)) & 0xff;
> > -	srb->cmd[4] = ((unsigned char) (start >> 8)) & 0xff;
> > -	srb->cmd[5] = ((unsigned char) (start)) & 0xff;
> > -	srb->cmd[7] = ((unsigned char) (blocks >> 8)) & 0xff;
> > -	srb->cmd[8] = (unsigned char) blocks & 0xff;
> > -	srb->cmdlen = 12;
> > -	debug("write10: start %lx blocks %x\n", start, blocks);
> > -	return ss->transport(srb, ss);
> > -}
> > -

Hello Marek, 

> 
> This stuff should be in a separate patch, otherwise it's not bisectable.
> Looks pretty OK otherwise.

Will take care in v7.

Best Regards,
Rajesh Bhagat 

> 
> [...]
> 
> --
> Best regards,
> Marek Vasut
diff mbox

Patch

diff --git a/common/usb_storage.c b/common/usb_storage.c
index 7e6e52d..41e5aa3 100644
--- a/common/usb_storage.c
+++ b/common/usb_storage.c
@@ -1046,11 +1046,11 @@  static int usb_read_capacity(ccb *srb, struct us_data *ss)
 	return -1;
 }
 
-static int usb_read_10(ccb *srb, struct us_data *ss, unsigned long start,
-		       unsigned short blocks)
+static int usb_read_write_10(ccb *srb, struct us_data *ss, unsigned long start,
+		       unsigned short blocks, bool is_write)
 {
 	memset(&srb->cmd[0], 0, 12);
-	srb->cmd[0] = SCSI_READ10;
+	srb->cmd[0] = is_write ? SCSI_WRITE10 : SCSI_READ10;
 	srb->cmd[1] = srb->lun << 5;
 	srb->cmd[2] = ((unsigned char) (start >> 24)) & 0xff;
 	srb->cmd[3] = ((unsigned char) (start >> 16)) & 0xff;
@@ -1059,28 +1059,10 @@  static int usb_read_10(ccb *srb, struct us_data *ss, unsigned long start,
 	srb->cmd[7] = ((unsigned char) (blocks >> 8)) & 0xff;
 	srb->cmd[8] = (unsigned char) blocks & 0xff;
 	srb->cmdlen = 12;
-	debug("read10: start %lx blocks %x\n", start, blocks);
+	debug("%s: start %lx blocks %x\n", __func__, start, blocks);
 	return ss->transport(srb, ss);
 }
 
-static int usb_write_10(ccb *srb, struct us_data *ss, unsigned long start,
-			unsigned short blocks)
-{
-	memset(&srb->cmd[0], 0, 12);
-	srb->cmd[0] = SCSI_WRITE10;
-	srb->cmd[1] = srb->lun << 5;
-	srb->cmd[2] = ((unsigned char) (start >> 24)) & 0xff;
-	srb->cmd[3] = ((unsigned char) (start >> 16)) & 0xff;
-	srb->cmd[4] = ((unsigned char) (start >> 8)) & 0xff;
-	srb->cmd[5] = ((unsigned char) (start)) & 0xff;
-	srb->cmd[7] = ((unsigned char) (blocks >> 8)) & 0xff;
-	srb->cmd[8] = (unsigned char) blocks & 0xff;
-	srb->cmdlen = 12;
-	debug("write10: start %lx blocks %x\n", start, blocks);
-	return ss->transport(srb, ss);
-}
-
-
 #ifdef CONFIG_USB_BIN_FIXUP
 /*
  * Some USB storage devices queried for SCSI identification data respond with
@@ -1105,11 +1087,13 @@  static void usb_bin_fixup(struct usb_device_descriptor descriptor,
 #endif /* CONFIG_USB_BIN_FIXUP */
 
 #ifdef CONFIG_BLK
-static unsigned long usb_stor_read(struct udevice *dev, lbaint_t blknr,
-				   lbaint_t blkcnt, void *buffer)
+static unsigned long usb_stor_read_write(struct udevice *dev, lbaint_t blknr,
+					 lbaint_t blkcnt, const void *buffer,
+					 bool is_write)
 #else
-static unsigned long usb_stor_read(struct blk_desc *block_dev, lbaint_t blknr,
-				   lbaint_t blkcnt, void *buffer)
+static unsigned long usb_stor_read_write(struct blk_desc *block_dev,
+					 lbaint_t blknr, lbaint_t blkcnt,
+					 const void *buffer, bool is_write)
 #endif
 {
 	lbaint_t start, blks;
@@ -1129,9 +1113,9 @@  static unsigned long usb_stor_read(struct blk_desc *block_dev, lbaint_t blknr,
 #ifdef CONFIG_BLK
 	block_dev = dev_get_uclass_platdata(dev);
 	udev = dev_get_parent_priv(dev_get_parent(dev));
-	debug("\nusb_read: udev %d\n", block_dev->devnum);
+	debug("\n%s: udev %d\n", __func__, block_dev->devnum);
 #else
-	debug("\nusb_read: udev %d\n", block_dev->devnum);
+	debug("\n%s: udev %d\n", __func__, block_dev->devnum);
 	udev = usb_dev_desc[block_dev->devnum].priv;
 	if (!udev) {
 		debug("%s: No device\n", __func__);
@@ -1146,11 +1130,15 @@  static unsigned long usb_stor_read(struct blk_desc *block_dev, lbaint_t blknr,
 	start = blknr;
 	blks = blkcnt;
 
-	debug("\nusb_read: dev %d startblk " LBAF ", blccnt " LBAF " buffer %"
-	      PRIxPTR "\n", block_dev->devnum, start, blks, buf_addr);
+	debug("\n%s: dev %d startblk " LBAF ", blccnt " LBAF " buffer %"
+	      PRIxPTR "\n", __func__, block_dev->devnum, start, blks,
+	      buf_addr);
 
 	do {
-		/* XXX need some comment here */
+		/*
+		 * If read/write fails retry for max retry count else
+		 * return with number of blocks written successfully.
+		 */
 		retry = 2;
 		srb->pdata = (unsigned char *)buf_addr;
 		if (blks > USB_MAX_XFER_BLK)
@@ -1162,8 +1150,8 @@  retry_it:
 			usb_show_progress();
 		srb->datalen = block_dev->blksz * smallblks;
 		srb->pdata = (unsigned char *)buf_addr;
-		if (usb_read_10(srb, ss, start, smallblks)) {
-			debug("Read ERROR\n");
+		if (usb_read_write_10(srb, ss, start, smallblks, is_write)) {
+			debug("%s ERROR\n", __func__);
 			usb_request_sense(srb, ss);
 			if (retry--)
 				goto retry_it;
@@ -1176,9 +1164,9 @@  retry_it:
 	} while (blks != 0);
 	ss->flags &= ~USB_READY;
 
-	debug("usb_read: end startblk " LBAF
+	debug("%s: end startblk " LBAF
 	      ", blccnt %x buffer %" PRIxPTR "\n",
-	      start, smallblks, buf_addr);
+	      __func__, start, smallblks, buf_addr);
 
 	usb_disable_asynch(0); /* asynch transfer allowed */
 	if (blkcnt >= USB_MAX_XFER_BLK)
@@ -1186,90 +1174,27 @@  retry_it:
 	return blkcnt;
 }
 
+
 #ifdef CONFIG_BLK
-static unsigned long usb_stor_write(struct udevice *dev, lbaint_t blknr,
-				    lbaint_t blkcnt, const void *buffer)
+static unsigned long usb_stor_read(struct udevice *dev, lbaint_t blknr,
+				   lbaint_t blkcnt, void *buffer)
 #else
-static unsigned long usb_stor_write(struct blk_desc *block_dev, lbaint_t blknr,
-				    lbaint_t blkcnt, const void *buffer)
+static unsigned long usb_stor_read(struct blk_desc *dev, lbaint_t blknr,
+				   lbaint_t blkcnt, void *buffer)
 #endif
 {
-	lbaint_t start, blks;
-	uintptr_t buf_addr;
-	unsigned short smallblks;
-	struct usb_device *udev;
-	struct us_data *ss;
-	int retry;
-	ccb *srb = &usb_ccb;
-#ifdef CONFIG_BLK
-	struct blk_desc *block_dev;
-#endif
-
-	if (blkcnt == 0)
-		return 0;
+	return usb_stor_read_write(dev, blknr, blkcnt, buffer, false);
+}
 
-	/* Setup  device */
 #ifdef CONFIG_BLK
-	block_dev = dev_get_uclass_platdata(dev);
-	udev = dev_get_parent_priv(dev_get_parent(dev));
-	debug("\nusb_read: udev %d\n", block_dev->devnum);
+static unsigned long usb_stor_write(struct udevice *dev, lbaint_t blknr,
+				    lbaint_t blkcnt, const void *buffer)
 #else
-	debug("\nusb_read: udev %d\n", block_dev->devnum);
-	udev = usb_dev_desc[block_dev->devnum].priv;
-	if (!udev) {
-		debug("%s: No device\n", __func__);
-		return 0;
-	}
+static unsigned long usb_stor_write(struct blk_desc *dev, lbaint_t blknr,
+				    lbaint_t blkcnt, const void *buffer)
 #endif
-	ss = (struct us_data *)udev->privptr;
-
-	usb_disable_asynch(1); /* asynch transfer not allowed */
-
-	srb->lun = block_dev->lun;
-	buf_addr = (uintptr_t)buffer;
-	start = blknr;
-	blks = blkcnt;
-
-	debug("\nusb_write: dev %d startblk " LBAF ", blccnt " LBAF " buffer %"
-	      PRIxPTR "\n", block_dev->devnum, start, blks, buf_addr);
-
-	do {
-		/* If write fails retry for max retry count else
-		 * return with number of blocks written successfully.
-		 */
-		retry = 2;
-		srb->pdata = (unsigned char *)buf_addr;
-		if (blks > USB_MAX_XFER_BLK)
-			smallblks = USB_MAX_XFER_BLK;
-		else
-			smallblks = (unsigned short) blks;
-retry_it:
-		if (smallblks == USB_MAX_XFER_BLK)
-			usb_show_progress();
-		srb->datalen = block_dev->blksz * smallblks;
-		srb->pdata = (unsigned char *)buf_addr;
-		if (usb_write_10(srb, ss, start, smallblks)) {
-			debug("Write ERROR\n");
-			usb_request_sense(srb, ss);
-			if (retry--)
-				goto retry_it;
-			blkcnt -= blks;
-			break;
-		}
-		start += smallblks;
-		blks -= smallblks;
-		buf_addr += srb->datalen;
-	} while (blks != 0);
-	ss->flags &= ~USB_READY;
-
-	debug("usb_write: end startblk " LBAF ", blccnt %x buffer %"
-	      PRIxPTR "\n", start, smallblks, buf_addr);
-
-	usb_disable_asynch(0); /* asynch transfer allowed */
-	if (blkcnt >= USB_MAX_XFER_BLK)
-		debug("\n");
-	return blkcnt;
-
+{
+	return usb_stor_read_write(dev, blknr, blkcnt, buffer, true);
 }
 
 /* Probe to see if a new device is actually a Storage device */