mbox

[PULL,REQUEST] i2c for 4.7

Message ID 20160527205914.GA1987@katana
State Accepted
Headers show

Pull-request

git://git.kernel.org/pub/scm/linux/kernel/git/wsa/linux.git i2c/for-next

Message

Wolfram Sang May 27, 2016, 8:59 p.m. UTC
Linus,

here is the second pull request from I2C for this merge window:

* one new feature (which nearly fell through the cracks): i2c-dev does now
  use the cdev API so it can handle >256 minors. Seems people do need
  that.
* two fixes for the just added DMA feature for i2c-rcar
* some typo fixes

Please pull. Thanks,

   Wolfram


The following changes since commit ea8ea737c46cffa5d0ee74309f81e55a7e5e9c2a:

  Merge tag 'nfs-for-4.7-1' of git://git.linux-nfs.org/projects/anna/linux-nfs (2016-05-26 10:33:33 -0700)

are available in the git repository at:

  git://git.kernel.org/pub/scm/linux/kernel/git/wsa/linux.git i2c/for-next

for you to fetch changes up to 72a71f869c95dc11b73f09fe18c593d4a0618c3f:

  i2c: dev: don't start function name with 'return' (2016-05-27 13:13:01 +0200)

----------------------------------------------------------------
Erico Nunes (1):
      i2c: dev: switch from register_chrdev to cdev API

Geert Uytterhoeven (1):
      i2c: rcar: should depend on HAS_DMA

Ludovic Desroches (1):
      i2c: at91: change log when dma configuration fails

Marc Gonzalez (1):
      i2c: xlr: rename ARCH_TANGOX to ARCH_TANGO

Moritz Fischer (1):
      misc: at24: Fix typo in at24 header file

Niklas Söderlund (1):
      i2c: rcar: use dma_request_chan()

Wolfram Sang (1):
      i2c: dev: don't start function name with 'return'

 drivers/i2c/busses/Kconfig         |  3 ++-
 drivers/i2c/busses/i2c-at91.c      |  2 +-
 drivers/i2c/busses/i2c-rcar.c      |  2 +-
 drivers/i2c/i2c-dev.c              | 25 ++++++++++++++++++-------
 include/linux/platform_data/at24.h |  2 +-
 5 files changed, 23 insertions(+), 11 deletions(-)