Patchwork sata_sil boot failure with 2.6.35

login
register
mail settings
Submitter Tejun Heo
Date Aug. 23, 2010, 1:58 p.m.
Message ID <4C727E80.3060402@kernel.org>
Download mbox | patch
Permalink /patch/62485/
State Not Applicable
Delegated to: David Miller
Headers show

Comments

Tejun Heo - Aug. 23, 2010, 1:58 p.m.
Hello,

On 08/23/2010 02:57 PM, Jan Beulich wrote:
>>>> On 23.08.10 at 12:28, Tejun Heo <tj@kernel.org> wrote:
>> This apparently is not an isolated case.
>>
>>   https://bugzilla.kernel.org/show_bug.cgi?id=16606 
>>
>> For some reason, the NODEV detection is getting triggered spuriously
>> which is really strange given that that part of code has been *really*
>> stable for very long time now.  Jan, can you please apply the
>> following patch and attach the kernel log?
>>
>>   https://bugzilla.kernel.org/attachment.cgi?id=27513 
> 
> Attached (but I think it doesn't tell more than what I already wrote
> in the original description).

Actually, it gives one more line.

  ata1: ST-ATA: DRQ=0 without device error, dev_stat 0x50

which is _really_ weird.  Hmmm... can you please apply the following
patch and see whether anything changes?

Thanks.
Jan Beulich - Aug. 23, 2010, 3:47 p.m.
>>> On 23.08.10 at 15:58, Tejun Heo <tj@kernel.org> wrote:
>   ata1: ST-ATA: DRQ=0 without device error, dev_stat 0x50
> 
> which is _really_ weird.  Hmmm... can you please apply the following
> patch and see whether anything changes?

No difference, but log attached again just in case.

Jan

Patch

diff --git a/drivers/ata/sata_sil.c b/drivers/ata/sata_sil.c
index 3a4f842..526d58e 100644
--- a/drivers/ata/sata_sil.c
+++ b/drivers/ata/sata_sil.c
@@ -183,7 +183,7 @@  static struct scsi_host_template sil_sht = {
 };

 static struct ata_port_operations sil_ops = {
-	.inherits		= &ata_bmdma32_port_ops,
+	.inherits		= &ata_bmdma_port_ops,
 	.dev_config		= sil_dev_config,
 	.set_mode		= sil_set_mode,
 	.bmdma_setup            = sil_bmdma_setup,