opts-global.c: Include gimple.h for LAST_AND_UNUSED_GIMPLE_CODE.
diff mbox

Message ID 1461205403-27885-1-git-send-email-raj.khem@gmail.com
State New
Headers show

Commit Message

Khem Raj April 21, 2016, 2:23 a.m. UTC
gcc/:
2016-04-16  Khem Raj  <raj.khem@gmail.com>

	* opts-global.c: Include gimple.h for LAST_AND_UNUSED_GIMPLE_CODE.

Fixes build errors e.g.

| ../../../../../../../work-shared/gcc-6.0.0-r0/git/gcc/lto-streamer.h:159:34: error: 'LAST_AND_UNUSED_GIMPLE_CODE' was not declared in this scope
|    LTO_bb0 = 1 + MAX_TREE_CODES + LAST_AND_UNUSED_GIMPLE_CODE,
---
 gcc/opts-global.c | 1 +
 1 file changed, 1 insertion(+)

Comments

Richard Biener April 21, 2016, 10:13 a.m. UTC | #1
On Thu, Apr 21, 2016 at 4:23 AM, Khem Raj <raj.khem@gmail.com> wrote:
> gcc/:
> 2016-04-16  Khem Raj  <raj.khem@gmail.com>
>
>         * opts-global.c: Include gimple.h for LAST_AND_UNUSED_GIMPLE_CODE.
>
> Fixes build errors e.g.
>
> | ../../../../../../../work-shared/gcc-6.0.0-r0/git/gcc/lto-streamer.h:159:34: error: 'LAST_AND_UNUSED_GIMPLE_CODE' was not declared in this scope
> |    LTO_bb0 = 1 + MAX_TREE_CODES + LAST_AND_UNUSED_GIMPLE_CODE,
> ---
>  gcc/opts-global.c | 1 +
>  1 file changed, 1 insertion(+)

I don't see build errors here.  How do you get them?

Richard.

> diff --git a/gcc/opts-global.c b/gcc/opts-global.c
> index 989ef3d..92fb9ac 100644
> --- a/gcc/opts-global.c
> +++ b/gcc/opts-global.c
> @@ -36,6 +36,7 @@ along with GCC; see the file COPYING3.  If not see
>  #include "plugin-api.h"
>  #include "ipa-ref.h"
>  #include "cgraph.h"
> +#include "gimple.h"
>  #include "lto-streamer.h"
>  #include "output.h"
>  #include "plugin.h"
> --
> 2.8.0
>
Alexander Monakov April 21, 2016, 10:33 a.m. UTC | #2
On Wed, 20 Apr 2016, Khem Raj wrote:

> gcc/:
> 2016-04-16  Khem Raj  <raj.khem@gmail.com>
> 
> 	* opts-global.c: Include gimple.h for LAST_AND_UNUSED_GIMPLE_CODE.
> 
> Fixes build errors e.g.
> 
> | ../../../../../../../work-shared/gcc-6.0.0-r0/git/gcc/lto-streamer.h:159:34: error: 'LAST_AND_UNUSED_GIMPLE_CODE' was not declared in this scope
> |    LTO_bb0 = 1 + MAX_TREE_CODES + LAST_AND_UNUSED_GIMPLE_CODE,
> ---
>  gcc/opts-global.c | 1 +
>  1 file changed, 1 insertion(+)
> 
> diff --git a/gcc/opts-global.c b/gcc/opts-global.c
> index 989ef3d..92fb9ac 100644
> --- a/gcc/opts-global.c
> +++ b/gcc/opts-global.c
> @@ -36,6 +36,7 @@ along with GCC; see the file COPYING3.  If not see
>  #include "plugin-api.h"
>  #include "ipa-ref.h"
>  #include "cgraph.h"
> +#include "gimple.h"
>  #include "lto-streamer.h"
>  #include "output.h"
>  #include "plugin.h"

The context in this patch looks like old contents of opts-global.c, prior to
Andrew MacLeod's cleanups in December 2015.  Here's how the includes look in
today's gcc-6 branch:

21 #include "config.h"
22 #include "system.h"
23 #include "coretypes.h"
24 #include "backend.h"
25 #include "rtl.h"
26 #include "tree.h"
27 #include "tree-pass.h"
28 #include "diagnostic.h"
29 #include "opts.h"
30 #include "flags.h"
31 #include "langhooks.h"
32 #include "dbgcnt.h"
33 #include "debug.h"
34 #include "output.h"
35 #include "plugin.h"
36 #include "toplev.h"
37 #include "context.h"
38 #include "asan.h"

Alexander
Khem Raj April 21, 2016, 2:01 p.m. UTC | #3
On Thu, Apr 21, 2016 at 3:33 AM, Alexander Monakov <amonakov@ispras.ru> wrote:
> On Wed, 20 Apr 2016, Khem Raj wrote:
>
>> gcc/:
>> 2016-04-16  Khem Raj  <raj.khem@gmail.com>
>>
>>       * opts-global.c: Include gimple.h for LAST_AND_UNUSED_GIMPLE_CODE.
>>
>> Fixes build errors e.g.
>>
>> | ../../../../../../../work-shared/gcc-6.0.0-r0/git/gcc/lto-streamer.h:159:34: error: 'LAST_AND_UNUSED_GIMPLE_CODE' was not declared in this scope
>> |    LTO_bb0 = 1 + MAX_TREE_CODES + LAST_AND_UNUSED_GIMPLE_CODE,
>> ---
>>  gcc/opts-global.c | 1 +
>>  1 file changed, 1 insertion(+)
>>
>> diff --git a/gcc/opts-global.c b/gcc/opts-global.c
>> index 989ef3d..92fb9ac 100644
>> --- a/gcc/opts-global.c
>> +++ b/gcc/opts-global.c
>> @@ -36,6 +36,7 @@ along with GCC; see the file COPYING3.  If not see
>>  #include "plugin-api.h"
>>  #include "ipa-ref.h"
>>  #include "cgraph.h"
>> +#include "gimple.h"
>>  #include "lto-streamer.h"
>>  #include "output.h"
>>  #include "plugin.h"
>
> The context in this patch looks like old contents of opts-global.c, prior to
> Andrew MacLeod's cleanups in December 2015.

Right. Ignore this patch, I forgot that I had local patches in OpenEmbedded
which should have been forward ported correctly.

 Here's how the includes look in
> today's gcc-6 branch:
>
> 21 #include "config.h"
> 22 #include "system.h"
> 23 #include "coretypes.h"
> 24 #include "backend.h"
> 25 #include "rtl.h"
> 26 #include "tree.h"
> 27 #include "tree-pass.h"
> 28 #include "diagnostic.h"
> 29 #include "opts.h"
> 30 #include "flags.h"
> 31 #include "langhooks.h"
> 32 #include "dbgcnt.h"
> 33 #include "debug.h"
> 34 #include "output.h"
> 35 #include "plugin.h"
> 36 #include "toplev.h"
> 37 #include "context.h"
> 38 #include "asan.h"
>
> Alexander

Patch
diff mbox

diff --git a/gcc/opts-global.c b/gcc/opts-global.c
index 989ef3d..92fb9ac 100644
--- a/gcc/opts-global.c
+++ b/gcc/opts-global.c
@@ -36,6 +36,7 @@  along with GCC; see the file COPYING3.  If not see
 #include "plugin-api.h"
 #include "ipa-ref.h"
 #include "cgraph.h"
+#include "gimple.h"
 #include "lto-streamer.h"
 #include "output.h"
 #include "plugin.h"